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ABOUT ANMMATE

Animate is a program that allows anyone to create
professional quality graphics animation with their Apple
computer. In fact, it's the utility we've been using here at
Broderbund to create some of the animation in our
products.

Utilizing the easy-io-use drawing and editing capa-
bililies of this program, you can easily create simpia ani-
mation sequences: balls bouncing, a man walking, a
bird fiying, etc. with just a few minutes work.

With & little more effort, detailed animated fiaures
can be created that follow intricate paths and timing
sequences over any double hi-res background, for truty
lifelike animation,

For the computer graphics doodler: Animate will be
fun and wiil help you develop your animating skilis, or
may even uncover skills you didn't know you had!

- Forthe experienced artist: Animate will be a useful
development tool for detailed, quality animation.

For the programmer: Animate's animation routines -
can be incorporated inta your own programs to give
themn polish and Hair, '

For the Dazzle Draw user: Animate can now take
Your computer screern masterpieces, such as land-
scapes and put moving animals on them; street scenes
and put animated peopte and cars on them; space-
stapes and put moving planets and rockei ships on
them: and coral reefs and have colorful fish swim
around them.

Animate, like #ts sister program Dazzie Draw, incor-
porales a large sat of very poweriyl tools, but is
organized in a way that makes these lools simple to use
and aasily accessible,
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Animate is really made up of two different pro-
grams; the Graphic Designer and the Scene Designar.
The Graphic Designer is used to develon your
characters and backgrounds using the drawing, editing

and preview features that are found in this section.
When Animate staris up, it always goes to the Graphic
Dasigner first,

In the Scene Dasigner you put logether your
characters and backgrounds, and even add sound and
lext, to create enlire animated scenes. Your scenes can
be saved on data disks, and if you want, you can even
rmake your own Show Disks which wili autematically run
the scenes. You can send these disks lo friends so they
¢an walch your creations too, since they don't need io
have Animate for a Show Disk o run!

For your convenience several characters and back-
grounds, already designed in the Graphic Dssigner, are
provided on the enclosed LIBRARY DISK and are ready
to be used in the Scene Designer.




This rmznual is givided into several parts to show
you how tc gt started and how to use all the features of

the progra

The tirst saection, Getling Siarted, telis you what
yoeu'll need o use the program and how to load it inlo
YOUP COmpiat

fiasics introduces the menus and general features
of the program.

The Graphic Dasigrer and Scone Designer see-
tions of the manual describe aifl of the available options
and menu lems in detail. icgether with step-by-step
examples.

The Agpendices provide lechnical information on
program feztures, color and ProDOS.

The Glossary includes brief definitions of all the
menius, funcions and terminology used in the program
and this manual,

|

Al the very end, you'tt
quick referznce,

ind a display of all menus for




GETTING STARTED ' T

WHAT YOIPLL NEED

START VT U

° Apple {le or 128K le.

» At least one disk drive, although two are recommendead.
= Color TV or monitar,

* A mouse, Apple Graphics Tablet, KoalaPad, or joystick.
* Biank disk(s) for saving your work.

Crpiional

+ Dot Matrix printer. _

> Apple ImageWriter I, Scribe, or Epson JX-80 color printer.

(Refer to Animale package for a complele list of printers you can use wiih the
program.

1. Insert the Animate disk into the disk drive, turn on vour moqnitor, and than
your compuiter. The program will load automatically.

2. Waituntil the red light on the disk drive goes out. An animated tille screer
will appear. Afler the animation is finished, anothar screen wili appaar and you
will be asked to select your input davice. Follow the simpie on-screen promds,
Once you've selected your input davice, press RETURN to continue.

4. At this point you will be asked if you want to save your setuo informalion (o
disk. If you plan to always use the same equipment, saving your setup will save
you time. )

4. Press HETURN. You will be asked to turn over the Animate disk. Aftar You
turn it over and close the disk ditve door, press any key and the prograns will go
directly to the main screen. (Note: Be sure to keep the Animate disk in the drive
while you are working with the program. Animate will need to load centain features
from the disk periodically.)

Prinfer Sstup

For Animale (o prinl properly you need to aiter cartain information about your
printer set-up. To do this, select number 2, Printer Setup, from the Utility denn and fol-
low the on-sereen prompls. If you have an Apsle lle, you will be asked 1o s2lect an
intarface card. if you have a llc, the program will automatically select-the Apple Supar
Serial interface.
Note: You can sel-up your printer while you're working with Animale {see inslructions
for Printer Setup under the Crown Menu on page 14) bul this setup cannet be 3
to dizk,




INPUT DEVICES =

MOUSE

APPLE :AF}

AQALAPAD

JOETIC

The best tools for using Animate are either a mouse or
an Apple Graphics Tabiet, Although you can use s draw-
ing pad or joystick, you'll have less control over the
CUrsor.

With your “artist’s tool” you can move the cursor (a
white poinler or other shape) around the screen to select
features from the program and to create your drawings.

This manual was written.assuming you will be
using a mouse. Depending on which input devics
you use, you'll want to keep in mind the instructions
below that apply

To select an Animate fealure, move the cursor by moving
the mouse on a clean, flat surface next to your computar
until the cursor reaches the feature you want. Press the
mouse button to highlight your choice, and then release
the button. This is called “clicking the mouse” To draw,
move the mouse while holding down the hutton. Then
release the butlon to finish a stroke.

Move the stylus on the surface of ths pad fo move the
cursor, Press the pen down in place of pressing the
mousea button.

Apply pressure to the tablet's surface to move the cursor,
Use the right pad button in place of the mouse buiton.

Move the joystick up, down, left, and right to move the ,
cursor, o move the cursor rapidly acrass the scraen, - \
press button O while moving the joystick. Use buiton | in
place of the mouse button.

To give you finer control over the cursor, whean using -
the Draw/Preview and Zoom features with the joystick
(see pages 15 and 16 in the manual), the arrow keys on
the Apple keyboard will also contral movement of the
cursor. Pressing the (3 {open apple) key legelher
with the arrow keys will move the cursor rapidly.

Note: The buttons on various dra\qu tabtets and
' Joystack. may vary.




HOW TO USE THE PROGRARM

If you haven't already done so, insert the Animate disk in
the drive, turn on your computer and foliow the prompts
to the main screen, This is the Graphic Designer portion
of Animate. Take a minute to study the screen, The ‘
boxes above the line at the top are menus, indicating the
options and features available. The empty space below
the line at the bottom will be filled with other options-and
features depending on the menu items you select. The
small while arrow is the cursor 1t will take on different
shapes, depending on the features you pick.
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FAEMNUS

. LMDQ BOX

: CURSOR —-
DRAWING AREA

%

MOVING THE
CURSOR

PULLING DOWN
MENUS

;Ammates features are hsted in “pull down menus" Th|s “
-means that you pull down” _each meny before selecimg
_ :a feature in the program. 7o take a look’ at !he_

R T e iR

S

The large blank area batweean the top and bottom
linas is your work area, This is where you'll draw your
characters and backgrounds, preview your animaled

work, and arrange your final animated masterpieces!

Before ydu .b'egin, practi.ce maoving the clrsar with the
mouse. You don't have to hold down the button. -

a;labie




HOW TO USE THE PROGHAM

CHOOSING
FEATURES

ABOUT WINDOWS

DRAWES 2
TooL v

LW
NOOW

'aCUVB

.. ExH Boxr L
T Lats you exit DrawlPrewew
L% and return io the mam -

E ‘menus. :

features, move the cursor to each menu, one at a time,
and press the mouse button. Like magic, a list of fea-
tures appears underneath each menu. Remember 1o
hold down the butten, or the menu will disappear!

To choose one of Animate’s features, simply puil down
ths appropriate menu. You'll also find a quick reference
menu al the back of this manual. Keep the mouse but-
ten held down and move the cursor ovar the fsature you
wani to hi ghltgh t, and then release the button. When a
feature is gray, it can't be highlighted, and selecling it

dl have no effect,

-]
Windows in Animate are the boxes that appear on the
scraen conlalning etther information about the program
or “tools” for using the various features.

Using Tool Windows

When you choose certain functions of the program, tool
windows appear al the bottom of the screen. A tool win-
dow is really like a tool box. it contains the tools you'll
need to use the feature you've picked. For exampla, this
is the screen you'll see if you selacl Draw/Praview from
tha Tools menu. Notice the too! window for this feature.
The tool windows for other features will vary in their
appearance. You'll find detailed descriptions of all the
ool windows in the program in this manual, For now,
take a look at the tocl window for Draw/Freview. It con-

tains the tollowing fealures:
SEQUENCED
FRAMES

Ex T BOX MARAE COUNTER

ACTIVE BOX

*E*% 0

CEL P PETTE T

SR H 0 ) n'm THRE:
IR S as :gs

TARDHAARF Y A NGRS LA RN GA ¥ NN AD G RS e

P ETTE

SEQUENCE CLEAR '
FRAMES  SEQUEM

SHAPEZBIZES

Nams
Idantifies

Praview Sslecior

Activates the previe:
dow when the word”
appears here, and p
away the preview wi
when the word “"OFF
dis p&ayed When it's
the preview Wlndow

Gpeead
Adjust the animation
speed in the preview
window.

the tool window.

Shapes/Sizas
Gives you a selection of
lwo paint brush shapsas,

. : Seguence Framas
and three different sizes.

. Lels you creale a custom
frame sequence,

f’-’a!eﬁe k £ available.

N !b you pic «ane o “3 Clsar Sequence -
oo Erases a custorn FTEVEF“‘J Winidow
Active Box sequence. Activaior '

- Activates the ammat
- .the preview window.

Tells you what co!or ;s | Sequenced Frames

" oGCountey -
- Indicates how many .
Cframes are_ln the current ;_ .
f'sequenc' s




HOW TO USE THE PROGRAM ==

WATLH THE
COLOMS!

TAKIMNG
THE PLUNGE

e

By now yeu have probatbly noticed that the little boxes
that contain the names of the meanus and features
change color from time o time. Eacs of these colors has
a specific msaning.

Blue or Gisen Yeliow ar Pink
It's okay to use this opticn.  You've jusi highlighted this
otior and it will be

{Gray sefecizd when you release
This option is currently the bition.

inactive. You can't use it

right now. Red

Agplizs 1o Undo only. Lets
you krow when the Undo
functicn is available.

We're now ready o explora the various features of Animate, As explainad earlier there
are two distinct sections in Animate the Graphic Designer, and the Sceane Designer.
When you boot up the Animate disk. the Graphic Designer's main screen always
cormes up first, :




THE GRAFHIC DESIGNER MENUS = =

Animaig's Graphic Designer helps you o creaiz and adit tha

- ture appears on the screen. You may use Help Aboui al 3r1 _poml to gu mh:arrrmtr*n
- -about an Animate feature in use. ; :

: When you are flmslmd willh- HPip Abou {be sure {e turn ove

indtvidual charactaes ¢
will appear in your animaled scenes. Essentially, any elerm=nt that is going to be 2«
of your mini-movigs has to first be created in the Graphic Designer.

The Graphic Dasigner provides you with the necegsary toois to draw characier
frame by frame, for cell-animation. For exampie. if you waniad to draw a falling re s
the first frame might show the rock near the top of the frame, and in each succes
frame, tha rock would be drawn closer and ciosar o the bottom. When the frames 2
sequancad together and previewed, tha rock will apoear fail lowards the grouna,

You can alsg draw stalionary backgrounds in thg Grapnic Designer, but a
graphics drawing program, like Dazzle Draw, is eveu ootter suiled for large scale
drawings. The drawing tools in Animale are designed for tha intricate detall of cai.
animation character drawing

All i the manu options in the Graphic Designer are dasaortbad in detall on the §
lowing pages.

The Crown menu includes fundamental features of the program, As an exercise,
select the first feature, About Animate. Hare's how you do it
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Move the cursor to the Crown menu.
Whan you reach it, hold down the mouse Gutton,

Awindow witn a message appears on the scresn.
3 o exit the feature and relurn to the main menus. click the mousa.

i
2

3. dMaw mova the cursor over About Animate and then refzase the bullon.
i
3

Harz ara dzscriptions of the features you'l find in the Crows menmn
Ahasut Anfmate ‘ - X

This fealurg is like a titla screen. It tells you who creatad amd puhl shed the program
and the publication date.

Halp About

This is a built-in assistance tool that lets you call up mme faipful mformallon about
the menu featuras and Undo. For a lillle haip from Animate, just click the mouse ove
Help Abow, turn over the Animate disk, and then move the cursor, now shaped. Iw- ‘
guastion mark, lo the appropriate feature. A window with a hrief description of the iz

ba{,k mm h dm drlve
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THE GRAPHIC DESIGNER MENUS : ——

Adjusi Color

The Adjust Color featuse puts color bars on your screen to help you adjust your moni-
tor. To exit, just click the mouse.

Printer Setup

This tealura altows you to change your prinler setup without having o re-boot the pro-
gram. 1f you have not aiready selected a printer setup, you can do so now. Animate
works on 2 variely of pooular printers, checi the labai on the back of the box for partic-
tlars. To get proper print outs you must let the program know whal kind of printer you'l|
be using. Herg's how!

i Puli down the Crown manu and select Printer Setup.
2. Aldialogue box” will appear on the screen.

3. The dizlogue box indicates three things: Tha name of the printer, the name of the
interface card, and the slot number your interface casd is in. I your printer, interface
card, or skt number do not malch these, you must change the settings. {If vou have a
he, you can oaly changs the printer settings.)

1 Tochange a setting, click the mouse on that item. The name will be highlighted
and the betiom section of the dialogue box will display your chaices, Click the mouse
aver the ug-and-down arrows to scroll through your choices, When you see the name
you want, just click over i,

3. o charge another tam, click the mouse over ths ftem you want to changa and
follows the same steps.

3. If you change your mind at any time during this procedure, fust click the mousae
over Cance! and Animats will restore the original names.

7. Onee you've made the desired sslections, simply click the mouse over Okay. The
dialogue hox will disappzar.

fo tast your printer, make sure your printer is turned on and “selected” then click Test
i the diglogue box. Tha message "Welcome to Animate” should print oul on your
svintec if your printer deasn't respond, try changing the setup informaltion. Qeeasion-
ally you may have to rebaol Animate it it stops warking after an inacourata aetup
Mote: Makes sure you've saved your work before selecting “Tesl”

Guil Andimate

“When you'rs ready to stop using Animate, this feature lets you remove the program
forn your computer's memory without turning off the system. You can then,start up
anothar program.

Vlara's how vou do it

Yoo Selaect Quit Animate from the Crown menu, :
oA dirlegue box appaars. When it asks you if you want lo quit the prograrn, click

ﬁ\

Eay of you do, and Caral if you dont,

0w probably nolicad that the Undo box has no features. This is because the

W, S RAs A unigle lunction. [ gives you the option of “undaing” the last
- for exampla, the last stroke you drew or section you ¢l or
3 option works only if you use iLimimadiately following the action you
: ‘e back, whan the Undo box is red. To undo an action, move the '
-curaor o Undo and click the mouss. R ) ERR

emnd
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THE TOOLES  The Tools menu provides the basic features you'll need
wav g to create your animated characters, as well as
MERU hackgrounds.

GARAWIPREVIEW  Draw/Proview allows you to edit and draw animated characters and lyackgre

Draw/Preview also has features which allow you o preview your creations i
Here is a slep-by-siap process for drawing a character, sequencing it, and i
its motion.

SEQURE
FRan:s
COUM

ORAVPREVIEW
TOOL WINDOW

HFEE j ; ] i
T T v % R
MY AL MR 0 i _! b ;

SECQENTE
FRAMES

i, Forthe purposes of this example, first pull down the Tools menu and ssl:
Frames. A tool window will appear al the bottom of the serean. Point {o the b
the number “18" in it and click the hutton. This will put a standard set of fram:
the screen for you to draw in.
2. Now we're ready to do some drawing. Pull down the Tools meny and selk
Draw/Preview. A ool window will appedr at the bottom of the screen. Pick the
you wani lo draw in by pointing to the dasirad color block and clicking the mc
pbutton. '
3. Next, select a brush by moving the peintar (o the desiréd brush shape an
andi clicking the mouse butlon,
4. o draw, move the pointer around within any of the frames on the screen
holding the butlon down. Release the button when you want o stop drawing «
lo another frame, Repeat this process in as many of the frames as you wanl.
30 Once you're finished drawing, the irames can be sequenced together If 4
Deen just doodiing around, your sequance probably won't make any sense. b
just ry for practice anyway. ' ¢
4. Move the pointer to the Frame Saquence icon and click the mouse buttor
that the pointer changes to a pointing finger, this means thal the Prograim is n
for you to select a frame sequence. . .
7. 1o pick a sequence, move the poiniar lo ine interior of any frame and clich
ton. The edge of the frame will lurn whita indicaling you just selocted it for the
sequencs, and the number in the right hand area of the tool window will incre:
indicating how masy frames you have sequenced so far, S
8. Selfect up to 255 irames —you ¢an aven select the same frame more than
. then move the pointer down to the = arrow and click the button repeatedly on
_arrow. Notice that the white frame border follows your sequence on the screen
© 3 To see your sequenced frames in action, move the cursor {o the Praviaw.&
. ‘altthe right of the tool window {the word "SEE” should be displyed here) and ok
~buttor, A proview window witl appear jn the middle of sergen. il you now move
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pointer to the 2 arrow and HOLD THE BUTTON DOWN You will see your sequencec
frarmes animate in the preview window, Selecting the - arrow, animatas vour
sequence in reverse,

0. The animadion in the preview window can be sped Up o1 slowed down by poinl-
ing to the speart arrow, holding the button down and moving the pointer. Once yoli've
sel tha speed, release the button and set the preview window in molion again.

. Togelrid of the preview window, move the pointer to the Praview Selector {it
should now say "OFF"} and click the button, The preview window will disappear, arnd
the white frame border will appear around the the frame that was lasi displayed in the
preview window.

[Note: The Praviow Selector to the right of the lool window wiil be gray, meaning it is
inactive, if na frame sequence has been selected

12. 1 you don't like a particular sequance, you can erase the sequence, without
? ' . allering your drawings, by sefaecting the Clear Sequence icon in the toof wincow,
: You can now define a naw sequence by repeating step 7 again,

While vou are working in DRAW/PREVIEW you can access the portions of the screen
that are hidden by Animate's menus and tool windows by pressing the ESC key. Press
ESC again to return to the menus and windows. (Undo can’l be used to take back a
brush stroke in the hidden areas.)

ZO0M  The Zoom featurs lets you magnify a smail segment of the screen so thal you can do
fine detail work by adding and deleting colors, pixel by pixel. You can work in even
finer detail with the Color option, in the Goodies menu. turned off. The Grid function,
also in the Goodiss mend, can further enhance your Zoom work. See page 24 for
instructions on using these featuras.

700
SCROLLER

JOOM ToOL i

WINDOW "
¥ £ 1 j 103 ] ! E !ifl
g AU G150 s LI g!ggi’,,;r;
oy I E SHHISHHETHEETHT . ;
PALETTE ACTIVE CURRENT E:F{;\M% AREA M 2000
COLOR  MAGHIFIED  SELECTOR
FRAME ‘

»

to Pull down the Edit menu and select the Zoom feature, (You should already have j
some frames on the screen with something drawn in them. not, follow steps 1 thry 4
ONn page 15 before continuing with this saction.) i
2. Adotted-line box will appear on the screen. To isolate the aren ofthe screen you
want to magnity, maove tha box to the desirad place and click the mouse.
3. The selected area will be enlarged to fiil up the enlire drawing area so you can
modify the drawing pixel by pixel, o
4 While you're working, you can “move around” within the frame by using the “zoom
~scroller” that appesrs In the Zoom tool windew. The zoom scroller is like a joystick that
directs the positioning of the magnified working area. Simply paint the cursor at the
“dot in the center of the zoom scrofler and hold down the mouse button. Then move
the cursor in the desired direction. col e TR BL
tf you've already defined a sequence of frames (see page 15) two arrows and a framne
number will appear in the Zoom tool window. The number indicates the frame you are
currently “zoomed in” on. To'_automaticariy z00m to other frames in the sequence just
- click either of the arrows. (NOTE: This feature will be available only if the the Upper feft
- corner of the Z0Om w a sequenced frame,) i1 i i

indow is placed WITHIN
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Working in your magnified section, hare's fiow to add and delste colors:

- 1. Pick a color.
2. Move the cursor to the pixel you want 1o color and cf;
than one pixel, simpiy hold down the button while movir als)
in-all the pixels,
3. IFyou change your mind and want o ©rase this color, click the mouse ov
pixef or pixels that have that color The pixels will turn black.

TR tha mouse, To o
e mouse until yo

MAKE FRAMES Make Frames allows you to make custom sized frames to s-“"rwlo‘se your chara:
(Noter When doing your first few animations you may find 1 easier to use the
Framtﬁ; oplion in the Teols menu to make your frames, ‘%m Apcendix V an pa
more information aboul frames.) -
Here's how to use Make Frames:
(Make sure the screen is clear If itisn't. select Clear Scres lq the Goodies »

0 f!
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ETHD, FRAMESR

il STND. FRAMES
- TOOL WINDOW

CUSTOM MASK

| BCENE DESIGNER

1. Pull down the Tools menu and select Draw/Preview.

2. Select the large round brush size and draw a few round balls randomly on the
screen by pressing and releasing the mouse button in different areas of the soreen
Draw as many as you fike, bui keep them spaced falrly far apart.

3. Pull down the Tools meru and select Make Frames. Motice the pointer changes
shape,

4. Paosition the pointer directly to the upper left of one of the balis. Hoid the button
down, and move the mouse diagonally to the lower right. You shauld see a frame sta
to form between the pointer position and the upper left corner. Keap maving o the
lower right until the frame complately surrounds the ball, then lat go of the mouse
button, ’

8. Hepeal this process for each of the balls on the screen.

& Once all of the balls have been surrounded by iramaes, they can be sequenced in
the same manner as described in the Draw/Preview sectiaon on page1s,

This option will instantly create a page full of standard size frames for your worshen
The first fow times you use Animate we suggest you creala your framas using chis
option instead of Maie Frames. See Appendix V on page 4t for mare informaiion
about frames.
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1. Select Sind. Frames from the Tools ment.

2. Atool window will appear indicating three different frare sizes. The numbars
indicate how many frames fit on a screen. The bigger the number, the smaller the
frame size, :

3. Move the pointer to a number and press tha bution. The screen will hecome full of
frames.

[Mote: This is an advanced feature, and is not necessary for using Animale
effectively] ‘

b

A"mask” makes it possible for a4 charactar to pass over a colored background ithou!
having the background “mix” with the character's colors or show through whers it
shouldmt. Animate automatically generates standard masks for all characlars,  The
masks themselves aren't visible on the screen, but are stored intern ally in the am-

puter's memory.)

Animate's standard mask considers any portion of a character that i3 black lo be trans-
parent, so any background that a charactar passes over will show thronghin thase
black areas.

i you need to change a mask for any reason, you would use this option. See Appen-
dix Vion page 42 for details. o -

This option atlows you to go to the Scene Designer o create an animated scens,
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THE BT The Edit menu gives you the option of editing your

‘ i
AT RIS waork. Using the Capture feature, you can work on any- ]
- R A . Lo ) . 3
0. thing drawn inside or outside of a frame. There ars also i
specific features which affect the framas and their con- i
. tents dirzclly. i
on I
- start I
=) »!
2 in
et
CASTURE
it onto the computar's invisible “clipboard” [or later use. {
the Gagture tool window is put away.) The Caplura f3aturs
can use the Flip, Invert, Cul, Copy or Faste featurss.
CAFTURE
TOOL WINDOV
yert

Hera's how to capture a section:

full of 1. Pultdown the Edit menu and select Caplura {
frames on tha screen, with someathing drawn in at !

~ steps 1 thru 4 on paga 15 belore continuing with this

""""""" : 2. Move the cursar to the upper teft cornar of the sacli
sure i's not over a frame boundary), and press the mous

button, drag the cursor to the lower teft and a dotigd-line

3. Whils continuing to hold down the mouss buiton, ma:

ZaAaron’
R R [P

wostarted yo

hout ted line surrounds the area you want to edil. Molies thal

F within a frame, you can't drag it past the frame boundaries. |

e 4. Relzase the mouse bution. The dofled line should rarmals whsm yo
- dotted line startod outside a frame and you draggad it P GE

aries it wilt disappear. Remember, you can only cantura EININL] COM]

or compiaiely outside of a frame.

rrans-
‘ To raka the dotted line disappear move the pointe: anyw = are on the
the scrasn and click the mouse button, :
oen- : :
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FLIF  With this feature, you can flip a captured section of your drawing vertically or
horizontally.

TURE AND FLIP
HORIZONTALLY

Here's how you flip a section:

i. Caplure the section you want to change.
2. Select Flip Horizontally or Flip Vertically from the Capture tool window.

IMVERT  The Invert feature lets you change colars in a caplured section of your drawing to their
“opposite” colors (such as while into biack).

Here's how you tnvert colors:

1. Capture the saction where you want to invert colors,
2. Select the invert aption from the Capture tool window.

THE GRAPHIC DESBIGNER MENUS ’
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| GUT AND PASTE  Using the Cut and Paste featuras together, you can remove the section you o
i . and reposition it in ancther area of your drawing. Here's how you do it:

T w gty S i T gt T T T T g

Eil {oolsii1Editl dhdodias)) it

File(Eniloo bl hnadias|); !

Liplttaes L il UL i3S B LA LI LA E L‘
e e T B e e

1. Capture the section you want to reposition.

2. Select Gut from the Edit rnenu, or type “x" on yeur keyboard. The capture
tior, will be lifted off your screan and placed onto the clipboard, in its placs wil
! black space.

! 3. Selecl Paste or typa V. A dofted-line box will appear indicaling the size o
| section aboul to be pasted.

i 4. Press the mouse button and drag the dolted-ling box to where you wanit t!
! ‘ tion to be relocatad. If you want to afign the seclion in a frame, drag the box s
i ‘ upper left corner is within the frame and, still holding the mouse button down,
the space bar. The dolted-line pox will dutorndtmaliy &hgn itsell within the fram
want to resuma moving the box, prass space bar again.

5. To paste the section, release the mouse bullon, r

SHORT CUT: For a one-step caplure-cut-paste follow this procedure:

4. Move the cursor inside the section youw've just capiured. f’w;s fhe mouse

down o "lift" the section.

2. Continue to press the but‘wn white you *drag’ the box to where you wani i

relocated.

3. Release the button. The aﬁonon wm be relocated instantly.

4. To make multiple copies while in the paste mode, type "CONTROL-v" and
“the mouse butlon each time you want a copy to pasted to the screen.




COPY AND PASTE
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with the Capy feature, you can reproduce a section of your drawing without remaoving
it and, by using Paste, place the duplicate onto another part of your screen. Here's

how:

[T514 e g I Fo Wkl RIS e b TR
!f : m:%!ii: i g?{}ﬂ‘!” E’-qijgl I\{‘{Q&i !.ﬁ;‘,’!ii.‘ ‘gfi%u‘ﬁ\i}l
S B S A AR B B SR R

PR AT

USRI 5 | NESHRRIFIR | ERPREENOIIN

i

HETE:

T
i

L '1!'!

{. " Capture the section you want to copy.

2, -Select Copy from the Edit menu or type “¢”. The captured secfion will be copled

" off the scfeen and placed or the computer’s clipboard. This time you w_on'_t.s_ee ablac

. space replacing it—the orginal remains onthe screen. . ... oo
‘3. Select Paste or type "V A thteq-iine_ b_px_will appear i_n’dicatir_}g the size of the .
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b *pasted” to the screer. You ¢an do this 851
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4, Press the mouse button and drag the dotizd-ling box to where you
tion to be relocated. If you want to align the seotion i a frame, drag th
upper left corner is within the frame and, stifl polding the mouse butto:
the space bar. The dotied-ine box will autormz: cally align itself within
wan! to resume moving the box, press space ©al again,

5. o paste the section, releasa the mouse ton.

6. To make multiple copies while in the pasts mode, type “CONTROL
the mouse bulton each time you want a copy nasted to the screen.

Use this feature to erase the contents of any trzme on the screen. (No'
is only avaitable while DrawiPreview or Guste™ Mask are selected, or

Frames has been used.) :

1. Using Draw/Preview and Make Frames from the Tools nignu, crea
frames on the screen and draw inside them.

9. GQelact Clear Image from the Edit menu.

3. Move the pointer to the inside of one of th= frames on the screen

bution. The contents of the frame will be clear=d to black.

The Copy Frame feature leis you convenient’y duplicate any frame on
comes in handy for making a series of cusior frames all the same si.
{Note: This feature is only available white Draw/Previaw or Custom M.
of just after Make Frames has been usad.)
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4. Create a frame on the screen using ’the‘-%ﬁai’(e _Frame feature in

.~ 2. Select Copy Frame from the Edit mems. -~ -

3. Move the painter to the inside of the frame on thegs_cf'eéh: and p
" dotted line will appear in the shape of the frame you just selected.

4. . Position the dotted line with the mouse and pres the button. A
any fimes as you want,
tp paste a frame within

“crass the boundaries of other _frg«:n,es.'or.iffgu
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This feature allows you to remove a frame without altering its contents. (Note: This fea-
ture is only available white Draw/Preview or Custom Mask are selected, or just after
Make Frames has been used.)

1. Using Draw/Preview and Make Frames fram the Tools menu, create several

~ frames on the screen and draw inside them.

2. Select Ciear Frame from the Edit menu.

3. Move the pointer to the inside of one of the frames on the screen and press the
button. The frame will disappear, but the the drawing inside the frame will remain on
the screen.

The Goodiss menu gives you just that—features that
let you enhance your work but which aren't essential
for using the program,

E:IZ'EM a

H!l' S

Fé i
E}Hsi%ﬁ G

I T

The Grid feature is useful whenever you magnify a section of the screen with Zoom. It ‘
helps you deting where the pixels are on the screen. Grid is active if there's a check
mark next to it. To use Grid with Zoom:

1. Select the Zoom feature from the Edit menu. '
2. When the magnified section appears o the screen, qele(“ Grid from the Goodies
menu, and resume your work.

The Color feature, used with Zoom, gives you the option of drawing fine detail in either
color or biack and white, While in Zoom, with the Color option active, you can draw
with all of the 16 colors available in Animate. With the Color option off you can draw in
black and white, and in much greater detail, since you have control over the smaller
parls of the screen, the bits, that define the doubie hi-res colors. :

The Color feature also affects painting with the Draw/Preview option, Ieitlng you paint
much smoother curves with certain colors when Color is off.

The Color option is "on” when there is a check mark by the word Colof in the Geodies
meny,

Clear Screen lets you erase the entire screen. Nole that your work wsll be, tost uniess
you save it to disk before clearing:

1. .Select Clear Screen from the Goodies menu.
2. Click Yes to conflrm your chome or Mo if you don't want lo erasa your Work
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PRINT SCREEN

PHRINT CHARACTER

THE FILE

DIGK DRIVES

FORMAT DISK

- with information on it, you il erase gverything on the disk.
‘5. When the formatting is completed you will have a data dtsk on which yi

8. Putthe Animate disk back in the disk drive.

- The Print Screen feature lels you print out the screen's work area on pape

color or black and white, depending on your equipment. Before you print,
check Printer Setup in the Crawn menu. Then simply click on Print Scree:
printing in the middle of a picture, press the ESC key.

The Print Character feature prints out a character in the sequence that you
it. Instead of printing the worksheet, only the frames you sequenced will b
the order that you defined. (See Appendix X on page 47 for tips on haw to
character print outs into animation “toys.")

The File menu lets yous save or retrieve your work- _
sheets, characters, backgrounds and scenes to and -3
from a separate data disk. You can also delele them
from the disk, and you can load Dazzie Draw and sin-
gle hi-res pictures,

Alt of the features in the File menu use a “dialogue | i

box’, a box that appears on the screen which sets up a g4 !ﬁ{:w
dialogue between you and the computer. Animate will dadalire
ask for specific information, like the name of the fiie, F‘E'm ﬁ% §‘g'§-;',
and you'll provide the answers. AR !17{?.‘

For convenience, it's preferable to use Animate with two disk drives. If your
only one drive, the program will prompt you to swap disks when necessary
) i

z
Before you can save your creations, you must prepare a disk to receive inft
from the computer. This is called "formatting your disk.”

You should have either a blank disk or one with data on it that you no long:
Whenever you format a disk thal’s already been used, ali the informaiion o
erased.
Here's how to format a disk: ‘
FORMAT: -
1. Select Format Disk from the file menu, :
2. Remove the ﬁmmai@ disk, and insert the disk you det to format in the
drive. '
3. Type in a name for your disk by following the rules for naming disks ani
described below.

4. If Animate finds information on the disk you are formalling, you must ¢
you really want to format the disk by clicking Okay, Remember, if you for mé

save your creations.
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FILES

LOAD

- LOAD SCENE
CIALCSUE BOX

CIRECTORY

- —
RULES FOR NAMING DISKS AND FILES
t. Disk names and file names must begin with & letter
2. Use only letters, numbers, or periods, separately or combinad,
3 Donot use any spaces or punctuation characters other than periods.
4. Do not use more than 15 characlars.
8. Use a different name for each disk, so you (and Animate) can tell

L them apart.

Thers are three different kinds of files that can be created and saved with the Graphis
Designer: Worksheets, Characters and Backgrounds.

A Workshest is any scrazn that has drawings on it. A Worksheet in Animate typically
contains character shapes enclosed in frames.

A Character is a series of sequenced frames from a Worksheet, You don't actually
“see” your character unti it animates, either in the preview window or in the Scene
Designer.

A Background is any drawing that is specifically used in the Scene Pesigner as a
backdrop for your animated scenes, '

Seo Appendix | on page 10 for more infarmation about the different files created by
Animate. ' '

|

'l ¢ 13 L g
| zn% |

ARROW

Ll

The Load feature lets you retrieve a saved worksheat, baékground or'scene. Here's
how it works: ' : . S . '

- 1. Sslect Load in the File meny,

2. Select Worksheet or Background depehding on what you want to ietrieve. {1t you

oad a Scene, Animate will take you direclly to the Scene Designer)

3. A catalog will appear in the dialogue box and a prompt at the top of the box say-
ing “Load Worksheet (or'Background, or Scene) named: oo T

A, Move the cursor 10 the name of the file you want to load ahd___é!_iféklh_e mo’useThe o

o5t

o -name will appear on the first line. §o o T, L R S e e
“o 8 Click aver Okay, and the Worksheet or Backg ound will appear on the screen
- when the loading is completed, R I IE R s
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The Save feature lels you save a workshest, character or background. Hers
works:

1. Select Save in the File menu.

2. Select Worksheet, Character or Background from the dialogue box, det
what you want to save,

3 Acal .og wilt appear in the dialogue box and a prompt al the top of the
ing "Save YWorksheet (or Character, or Background) as:'

4. Tlype in the name. I you are re-saving a file already fisied, click over the
5. Click aver Gkay.

Delete PERMANENTLY removes files from the disic

1. Select Delete in the File menu.

2. Select Worksheet, Character, Background or Scene from the dialogue t
depending on what type of file you want to delete.

3. A calalog will appear in the dialogue box and a prorpt at the top of the

ing "Delete Worksheet (or Character, or Background, or Scene) named:”

4, Click ovar the desired file name. The name will appear on the first line.
8. Click Gkay to confirm that you want to delete that file.

This feature aliows you to load single hi-res and double hi-res pictures creal
programs other than Animate, and allows you to save them as eithar Works!
Backgrounds, Single hi-res pictures that are loaded into Animate wifl autom:
converted to double hi-res.

1. Select Transfer Pic in the File menu,

2. Select Load.

3. A catalog will appear in the dialogue box and a prompt al the top of the
ing “L.oad Picture named:”

4. Move the cursor to the name of the file you want to load and click the mx
name will appear on the first line. .

5. Click over Okay, and the picture will appear on the screcn whan the loac
completed.

You can atzo uss Transfer Pic 10 save a Worksheet or Background ag a sing!
ble hi-res picture so it can be used by other graphics programs.

1. Select Transfer Pic in the File menu,

2. Select Save,

3. A catalog will appear in the dialogue box and a prompt al the top of the
ing "Save Picture named."

4. Typeinthe name. if you are re-saving a file already listed, cilck over the
8. Click over Okay.

6. Choosz whether you want 10 save as a Single Hi-res or Double Hi-res pi
you save as a single hi-res picture, Animate will convert it,

7. Click over Okay.

[Mote fo Dazzle Draw Users: Use Transfer Pic to load your Dazzle Draw pict:
Animate, or use Transfer Pic to save your Worksheets and Backgrounds as ¢
res piclures so you can do further work on them in Dazzle Draw. See Appeanc
page 40 for move information about using Dazzle Draw with Animate, ]

Make Directory gives you the option of organizing your disk files into cé[egor

~Subdivisions. For example, you might want to file all of your animal character
Hogether. This feature makes it easier to locate files. If you want to create mul
. categories, you should make a directory before yOu save your work,

_ For example, Iets say you want to create a subdirectory cailed 'Ammals to d[
: _your animal characters from any othefs Here's how you clo o ‘

L Select Make D:rectory from the Fi!e menu
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2. Type “Animais’ and click over Okay. Your new category will now be filad away in
the disk directary. :

2. 7o file characters under “Animals”, change the name of the Prefix. To do so, clict
over Prefix, and then over "Animals” in the disk directory.

4, Click over Okay or press return.

5. Naext time you want to save a picture, itwill automatically be fited under "Animal:

Once you have selected one of the fita functions, Save, Load, Delete or Transier Pic
and are at the dialogue box with the catalog, you can select a particular directory o
that disk, or select a different disk, by using the PREFIX and ON LINE functions av:
abie in the dialogue box. .

To select a subdirectory:

1. Click Plefix, '

2. Acatalog will appear in a dialogue box and a prompt at the top of the box sayin
“Set Prefix to:”

3. Click over the desired prafix,

4. Click Ckay.

To select a different disk:

i. Click On Line.

7. Speiect one of the disk names from the catalog. The new name will automaticall
become the new Prefix.

3. Click Okay. Any further disk operations will now affect the disk with the nams y
selected, -

Nofe: If you insert a different data disk in the drive, since your iasl disk access, Ani-
mate will automatically recognize the new disk as the current data disk the next v
you want to load or save a file.
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|

Animate’s Scene Designer allows you to create your own animated sce
characters and backgrounds drawn in the Graphic Designer.

The Scene Designer provides you with the necessary toals o selact i
and backgrounds you want, assign moverment paths to your charactsrs
and text to your scene and much, much more.

All of the menu options in the Scene Designer are described in detail o
pages. ““:3_:-

What is 8 Scene?

A scens is an animated cartoan which contains one or more characts::
and pessibly some text and sound.

To create a scene you must first assemble the necessary building blonk
have al least one characler that has been created and saved from the ©
Designar, or you can use one of the characters supphed on the encloss
Although you can use the clear btack screen for a background, your s
made more interesting if you use a colorful background. The backgrour
drawn with Animate, Dazzle Draw, any double hi-res drawing utility, or y
one of the pre-drawn backgrounds on the Library Disk.

Once you've gathered your building blocks ait you need o do is tell you
what to do and where tc go in your scene. You do this by defining paths
character, When the scene is run, your characters will {oliow these pai
At any point during the creation of your scene, you can insert text into i
handy way to have on-screen characters talk, ot to have a descriplive n:
your scene. You can also add a soundtrack lo your sceng uging Animat:
editor. :

Once you finish crealing your scene, you can sit back and watch # run !
to end; just like a cartoon on TV!
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MAIN CHARACTER  When you first enter the Scene Designer you are presented with the Main Character
SCREEN  Screen, which looks like this:

j
SCoNE DESIGNER T IO AT FTRI ;
MA!N c}'{AP::?‘ER SCREEI‘IJ ‘-‘Td | !g ;H!{\?b‘;jg E"g:{jn't§ ;({jli(uugg‘!x% :; ! T P hAENUS
i Betasbiidy b ot A L SR A bl o
|
| f
t' CURSER —1—% oo s st er et e , N
: Characters: .
:’ SRR e~ CHARACTER OISPLAY
!
f !
CHARAGTERS ,
E 5
T e
?I%”F‘E;,S”i}il ~ FRAME CYCLE
iLaﬁ:F
............................................... AL
. ot et o »
CUARENT FRAME —HIE Famas 0000 Al e |
Smipta s SO SIRRRIEFEETRY h i nm‘;mm‘.'tml {Eﬁ} t e SUN SCENE
fotali 0000/  fipriority hdl |
/ i |
TOTAL SCENE  FRAME SETCHARACTER  RESTORE MAL
FRAMES SELECTDR  PRIORITY CHARACTER

SCREEN

The Main Character Screen contains several important features lo he'p you creale a
sceng,

Characters:

‘ The targs yetlow rectangle displays the names of the characters that nave besn

! loaded from a data disk. You can load up to 16 characters, totaling ne more than 255

; framas, into the Scene Designer at any one time. The highlighted character will be the
one that you will currently be working with. To select another characier simply rmove
the cursor to its name and click the mousa button. '

Character Diaplay:

]
The selected character wili be displayed on the right side of the screen, A number in
the lower right indicates which character frame is being displayed. At the bottom are
two sets of arrows that are used to regulate the beginning and end frames of your
character's animation cycle. o B

Frame:

- The number here represents the current selected frame in your scene. You can select

a particular scene frame by stepping through the scene with the arrows, or youcango
directly to a specific frame by clicking on the word Frame and typing in.a frame -+

_ - It you press ESC you can view the entire screen. While viewing the entire screen, use .
= the arrow keys on the Apple keyboard fo step through the scene. Press ESC againto -

.' T@iaﬁi; _ B R S S ‘_ __
' This rumber indicates the total number of frames in VOUID s6pns
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Prigrity:

Priority determines which characters arg “in front” or “in back” of each other in
scene. As each character is inserted into a scene, it is assigned a scresn prios
later the character is introduced, the higher the priority. So that your first char:
initially pass hahirg your second character, elc. You can alter the priority for a
in your scers by s=iecting Priority and following the prompts,

Gigr:

Click Gio to have your entire scene run from beginning to end. While the scer
ning the foliowing =ayboard options are available:
space bar — Dause
speed up {scanes always start out at their maximum speed)
fow down :
:start scane
s2op the scene and go back to the main screen

[t
s

RETURN-—
EEC--

Festore Main Charaster Screen:

This icon will app=ar when your scene occupies the work area of the screen.
Clicking over this izon wiil restore the Main Characler Screen.

The Crown menu
the Graphic Desig

cludes fundamental features of the program and is descril:
=r section of this manual on page 13.

The Fite manu etz yau retrisve characters, hack-
grounds and scen=s from a separate data disk, and
alsa lets you save wour scenas.

In addition, tha file menu lets you create Show Disks
that will rus vour scenes without reqguiring the Animate
program.

All of the features in the File menu use a “dialogue frant

box’, a box that aporears on the screen which sets up PR

IR
a dialogue baiweer you and the computer. Animate F@;i,ﬁﬂﬂ .’.“% L
will ask for specific information, like the name of the b “E, H, il
. b ) fale; . ji
file, and you'it provi<ie the answers, AT JL

For conveniencs, it's preferable to use Animate with two disk drives. 1 your syst
only cne drive, the grogram will prompt you to swap disks when necessary.

S — i R

The Load feature le*s you retriave a saved character, background or scene.
1, Select Load from the File menu.
1, ackground or Scene depending on what you want to rol

3. Acatalog will appear in the dialogue box and a prompt at the top of the box
ing “Get Character for Bacxgruund or Scene) named:”

- 4. Move the cursar {o the name of the ftie you want to load and cltc:rc the rmous

name will appear on the first line.
5. Click over Okay and the file will load. .

U After loading a baclk ,ﬁgrouad or scene Animate wm return you to the Scene Dess{
-~ Howsver, when loag
. all.the characters y

ng characters, steps 3.thru § can be repeated untit y@u ve, i
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SAVE SCENE

MAKE DERECTORY

FORMAT DISK

MAKE BHOW DISK

Onee you've put together an animated scens, you can save it to a dala disk:

1. Gelect Bave Scene in the File menu.

2. Acatalog will appeat in the dialogue box and a prompt at the top of the box say-
ing "Save Scene named;”

4. Typein the name. |f you are re- suvsng a scene already listed, click over the name.
4, Click-over Qkay,

If you save a scene to a disk that does not contain the appropriale background fite for
that scene, Animate will automatically transfer the background to the new disk. Just
follow the prompls on the screen when Animate asks you to swap disks.

I3

See page 27 for instructions on how to delets files from a data disk, :

Seq page 27 for instructions on how lo create a directory on a data disk, j

See page 25 for instructions on how to format a new data disk.

A Show Disk is a special data disk that will automatically run scenes that are saved on
it by simply boating it. These disks can be sent to {riends or relatives with computers
ke yours, and they dor't nead to have the Animate program to see your craations.
The Animale Demonsiration Disk is an example of a Show Disk.

To make a Show Disk follow this procedure:

1. Select Make Show Disk in the File menu.

2, Follow the instructions on the screen and insert a blank disi into the disk drive.

3. Select Okay. ‘
Once the computer is finished, the disk is ready to have scenes put on it, By using the W‘
Load Scene and Save Scene fealures you can load a scene from one of your data ;
disks, and save it onte the Show Disk. (The number of scenes you can save on & show
disk is determined by several factors: The length of each scene; the number of
characters each scene contains; and how many backgrounds are used.)

When you're finished, simply Quit Animate and boot the Show Disk. The Show Disk
contains a special program that allows you t to select the order in which t hb scenes are
to be shown. When your scenes are running, the following keybaard opnons are
available: . '

. space bar— pause
' -+— spaed up
- glow down
RETUF{N-_ restart scene
' TAB — - skip 10 next scene
ESC— stop the scene. Al[ows you to reoequence the scene order
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THE TOOLE  The Tools meny provides the neczssary fealures you

RENE needto choreograph the movemsnis of vour charac-
ters on the screen. This is done oy defining paths for
them to follow.

Paths can be defined in three ways: You can move the character direct!
mouse, or you can “lead” Ihe charzsier towards a destination with the 1
finally, you car move the characie: direct using the keyboard.

When vour scane is run, the chars

wers will foltow the exact paths you'v

You ¢an also edt back to ths Grap .o Designer thru the Tools menu.
SET PATH This is the quickest and sasizst masfod far defining a character’s path:

Load one or more charasiers tsing (e Load option in the Fite ment
2. When you are back at the main screen, select one character by clic
name.

2. Select Set Path Directly in the Tols menu.

3. a  The screen will clear to the packground, and the character you
appear in the canter. Withou: pressicg the button, move the mouse back
The character wili follow your move
0. Move the character to a stz
¢ Hold the button down and -

3 grositien on the left side of the s

ihe mouse slowly 1o the right. T

will run through its pre-drawn anis on oycle as it follows the mouse. W,
ton is held down, the compuier “recerds’ the movements of the characte
button is not pressed, the computer does not "record” the characier's mo

- 4. When you are finished making & path for your character press the
accept the path and go back o the rzin soreen. If you don't iike the path
defined and want to try again, press ne DELETE key instead, and the cc
erase the path you just creatsd.

Note: While “recording” your characters movaments, the computer will i
audible click as sach frame passes T togite the clicking sound on or of
key,

Additional Characters:

To add more chzracters to your scere. select a new character, find the fra

youwant the new character invoduns {by clicking the arows, or the Fra:

the main screen) and simply ¢efine 2 patn for the new tharacter. You can
. _Imany as 16 characters in your scens. .

SET PATH BY  This method of defining 'alpath is va}fgf'useiui for straight line paths feadine
: LEADING destinations. - ' S . : -

. 1. "Load one or more characters usig the Load option in the File menu.
" w2, When you are back at the main screen, select one character by clickii
3. Select Set Path By Leading in the Toois enU.
4. a. A dialogue box wilt appear asking you lo select the speed at whic
character will follow the mouse, Set tha speed by dragging the speed poin
esired position on the sliding scale. i R e

ckaver Okay. =




THE TOOLE  The Tools menu provides the necessary features you
BMENU need to choreograph the movements of vour charac-
' ters on the screen. This is done by defining paths for

X say- them to follow.

name.

file for
Just

Paths can be dafined in three ways: You can move the characier directl
mouse, or you can "leed” the character towards a destination with the
finally, you can move the character directly using the kayhaard.

When your scene is run, the characters vill follow the exact paths you'v.
Yau can alse exit back to the Graphic Designar thru the Tools meny.

SET PATH  Thisis the quickesl and sasjest method for defining & characters path:
HEECTLY i,

Load one or more characters using the Load option in the File men:.
2. When you are back al the main screen, select one character by clici

name,
T 2. Select Set Path Riractly in the Tools menu.
ad on d.a. The screen will clear to the background, and the character you .
ters appear in tha center, Without pressing the button, move the mouse back

The character will follow your movernents. 7
b.  Move the character io a starting posilion on the lelt side of the «
¢. Hold the button down and move the mouse slowly to the right. T
will run through iis pre-drawn animation cycle as it foliows the mouse. W)
ton is hald down, the carputer “records” the movements of the chay acles

/8, ‘ button is not pressed, the computer does not “record” the characier's mo

4. When you are finished making a path for your charactar press the B
qthe - accept the path and go back o the main screan. If you don't like the path
; ‘ defined and want to try again, press the DELETE key instead, and the co
show ' erase the path you just created.

Nete: While “recording” your characier's movaments, the computer will m
audible click as each frame passes. 1o toggle the clicking sound on or of

3k key.

Tare
Additional Characters:

To add more c¢haraclers o your scene, select a new character, find the fa
you want the new character introduced (by clicking the arrbws, or the Fra
the main screen) and simply define a path for the new tharacter, You can
many as 16 characters in your scene. .. :

SET PATH BY  This method of defining a path is very useful for straight line paths leading
LEADING destinations. o _
' - 1. Load one or more characters using the Load option in the File menu.
. 2. When you are back at the main screen, select ong character by clickii
- % Select Set Path By Leading in the Tools menu, = wd o e
8. -a’ Adialogue box will appear asking you to select the speed at whic

' ~character will follow the mouse, Set the speed by dragging the speed poin

- desired position on the sliding scale. Glick over O
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by reshuffling them within the scene, or copy one sec-

b. The screen will clear to the background, and the character you sslectad will
appear in the center. You will also see the cursor arrow and a small dot beneath it. The
arrow and dot indicate the topmost and bottormmaost points, respectivety, of your
character’s cell frame.

¢ Select a starting position for your character, by holding down the €1 {open
apple) key and moving the mouse. The computer does not “record” this movement.

d. Select a destination for your character by releasing the O (open appie)
key and moving the cursor to the desired place. The character will remain behind at
the starting position,

e. To have the characler move towards the destination, hold the mouse buttan
down. The character will start to go through its pre-drawn animation cycle as it movas
towards the cursor. While the button is held down, the computer “records” the move-
ments of the character. When the bulton is not pressed, the computer does not
“recard” the character's movements,

& \When you are finished making & path for your character press the EGC key to
accepl the path and go back to the main screen. If you don't like the path you just
definad and want {o Wty again, press the DELETE key instead, and the computer will
erasa the path you just created.

(See page 33 for information on adding more characters to your scene.)

This method of defining a path is ideal for very detailed positioning of characters in
your scene, since you control the path frame by frame, pixel by pixet, and you don’t
have to worry about an unsteady mouse.

1. Load one one mare characters using the Load option in the File menu.
2. When you are back at the main screen, select one character by clicking on its
name,
3. Select Set Path With Keyboard in the Tools menu. The screen will clear to the
background, and the character you selected will appear in the-cenler.
4. o, Move the character to a starting position on the screen with the arrow kays,
or by holding down the mouse hutton and moving the mouse.

b. ‘To animate your character, press the space bar. The character will advance
one frame of its pre-drawn animation cycle,

c. Advance the character to the next position on the screen with the arrow keys
or the mouse. Gio back to step 4.b. to "record” the next irame.

d. Continue repeating steps 4.b, and 4.c. until you are finished.
5, Press the ESC key to accept the path and go back to the main screen. If you don't
jike the path you just defined and want to try again, press the DELETE key instead,
and the computer will erase the path you just created. -

(See page 33 for information on adding more characters to your scene.)

This option allows you to go back to the Graphic Designer saction of the program (o

edit and creale characiers and backgrounds, ‘
i

The features in the Edit menu aliow you to make : ? - *;f
changes or fix mistakes in your animated scenes. You J
can alter the sequence of frames, characters or sound,

. tion of your scene to a different place in the scene, or. .~ E
© you can simply deiete enlire sections or characlers. C

Sl
| 3 o
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MOVE  This option lets you move a section of frames, sound, or of a character
location in a scene to another.

tove frames

}?ta%ﬁ'&'” Qggr.;lg A b From
Total 0734 0100

1. Define a character path by following the instructions for Set Pati Dir
Tools manu.

Z, Select Move in the Edit menu.

3. Adialogue box will appear asking you which element in the scene ¥
Move: Frames, Character or Sound. For our exampte select Frarmes and
(The process is identical for Characters and Sound.)

4. Click on the word From at the botlom of the screen,

5. Select a frame by clicking on the Frame box and typing a number, o
arrows to step through the scene to the desired frame.

&.  Click on the word Thru at the bottom of the screen. Repeat step 5 1o
frame.

7. Click on the word To at the bottomn of the screen. Hepml step & agai
8. Click Okay. The range of frames starting with From and bndmg wWih
“pasted” in at the frame specified under To, and “cut” from their original I
8. If you don't want to make any changes, click Cancél instead of Criay.

CaBY  This option lets you duplicate a section of frames, sound dr a characiar's
- one location in a scene to another. :

3. Definea r;:haracter path by fol%owmg the instructions for Set Path Dlrs
fools meny, -
2. Select Copy in the Edit menu,
3. Adialogue box wili appear asking you which elermant in the scene yc
Copy: Frames, Character or Sound. For our example select Frames aﬂdt
(The process is identical for Characters and Sound. ) :
4. “Click on the word From at the bottom of the screen. -
-8, Select a frame by clicking on the Frame box and typmg a number or
S arrows to step through the scens to the desired frame ] o
.8, Clickon the. word Thru at the bottom of the screen. Repeai step 5 to
BT -frame g :

o -':'7’ : Chck on the word To at the bottom of the screen Repea step 5 again
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DELETE

CLEAR PATHS

CLEAR BG

CLEAR ALL

THE GO

SODIES
ME "’é%ﬁ

“The Goodies menu containg special features and utiti-

8. Click Okay. The range of frames starting with From and ending witr Thru wili be
“pasted” in at the frams specified by To.
8. H you don't want io make any changes, click Cancel instead of Oley

This option lets you dalete a section of frames, sound or a character's cath from a
scene.

1. Define a character path by following the instructions for Set Path [0 solly in ths
Tools menu. '

2. Select Delete in the Edit menu.

3. A dialogue box will appear asking you which element in the scene FOU want o
Delete: Frames, Character or Sound. For our sxample select Frames znd click O ay.
(The process is identical for Characters and Sound .}

4. Click on the word From at the bottom of the screan.

5. Select a irame by clicking on the Frame tox and typing 2 numier, o use the
arrows to step through the scens (o the desired frams,

6 Click on the word Thru at the bottorn of the sereen. Ressal slep 5 to sstect =
frame.

7. Click Okay. The range of frames starting with From and ending witt: Thru will ne
dedeted from the scens.

8. #f you dont want to make any changes, click Cancel inszad of Okay

This feature will erase all character paths in vour scene.

i.  Select Clear Paths in the Edit menu.
2. Adialogue box will appear asking you 1o verify your selzction. Click Yes to
contirm,

Use this feature to erase the background to black.

1. Select Clear BG in the Edit menu,

2. A dialogue box will appear asking you to verify your seleclion. Click ¥es to
confirm. :

This feature will remnove all characters, paths and the backaround from tha com
memory. Do this anly whan you want to complstely start over dg&m wsti: raw ch
ters and a new background, -

1. Select Clear Alf in the Edil menu,

Z.  Adialogue box will appear asking you to verify your selection. Click Yes to
confirm, ,

ties that you can use to embellish your scenes.
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COLOR  This feature allows more detailed path motion i you are usi
chrome monitor. If you are using a color moniior, you wilt o
fealure is turned off.

g Animate with
strange resulis

The Color fzature only affects your scane when youi are d=iining saths for o
i the scene was created with Color off, it will ALWAYS run w ith Color off,

Color is “or”™ when there is a check mark by the word Coler in the Goodies

STAMP  Stamp is a spacial effect that causes an animated i characia~ tojsave an imp
itself on the background as it moves acrass the sorean,

Bt S o - sy
R

SRR R A

S i

Y s

1. Goet one or more characters u%mq the L{mci optionin the
2. When you are back at the mcun screen, seiact one chars
name, :
3. Gelect Stamp under the Goodies menu. A check mark sk
the word Starnp in the Goodies menu-this means that the &
is “on.
4. Select Set Path Directty under the Tools menu.

~ 5. Hold the mouse button down and move the character gn &
the stamp feature makes the character leave an imprint of 1t$
6. Whenyou are finished press £SC.
7. To turn "off” Stamp, select it again, and the check mark widt disappear,

=ie monu.
a1 ty clicking o

uld now appcar
mpospecial effe

ne screen, Notic
£ on the backgre

TE);(‘!" This option aflows you to insert text into yaur ammated sceneﬁ Thm text wm ap
~.. 8 frame you desagnate and wﬂI remaln in your scene untal ycu eige e REMO\
TEXT feature. : . AT Ery

: R Create a \)CEF’IG by fcilowmg the msi‘ruc lorz:, fc), _ z Path

“inenu. : ¥
2. Find ths f*‘ame where you want the (exl to appear by steh
L wﬂh ihe ar TOWS at ihe botlom of the mcnn scroen. -

f@@.’f‘?‘xf in the Tod

ng trough the|
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REMOVE TEXT

PRINT SCREEN

SOUND

Hi, my name is
Dave and | love

3. Setect Text in the Tools menu.

4. Position the cursor on the screen to indicate where you want the lext io appeal
and press the bution. A blinking vertical bar will appear indicating that you can
begin typing your iext.

You can type up to five full lines of text. When you aie finishad, press the ESC key.

3

Once text has been added to your scene it will remain there until you use this feature
to remove it

1. Add text to your scene by foliowing the instructions for Text in the Goodies menu.
5. Find the frame where you want the text to disappear by stepping through the
scene with the arrows at the bottorn of the main screen. R should be one or more
frames past the point where the text was inseried,

3. Select Remove Text in the Tools menu.

4. Point to the text you want remaoved, click the button, and the entire phrase will
disappear.

This feature allows you to print any single frame, or “stifl* from your apimajed scene.

1. Creale a scene by following the instructions for Set Path Directly in the Tools
mentt,

2. Find the frame you want printed by slepping through the scene uUsing the arrow
keys at the bottorn of the main screen. _

4, Make sure there Is paper in your printer, and your printer is ox.

4. Selecl Print Screan in the Goodies menu. , |

110 the animation. This is done by spreading the musig throughout the scens,

This feature aliows you t¢ integrate sound into your animated scene.

'HOW SOUND WORKS IN ANIMATE

~When you run a scene that includes sound, the animation stops while the com- -
puter plays any notes that it encounters in each frame. The more notes thata .
‘frame has, the longer the animation must delay. ' IR o

This Is fine if you want your scene to pause at certain poinits with ni_usi@ pléyihg.‘_'-'.
But if you want the music to play along with the animation, you have to "synch” it =

' entering only one fote of music per frame, of even one note per.every two or-:
“three frames. This way, the animation only stops for very short periods at any -
~one time to play a note. }'s recommended that you use notes of as short & dura-
tion as possible when impleménting this technigue. - AR At A R
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Here is a step-by-step guide to the features found in Animate's sound editor:

A

SOUND EDHOR

ERIBIER A,

MUSICAL STAFF

OFTIONS

CURRENT FRAME —ii

FRAME SELECTOR —- -2

KEYBOARD

HOTES HESTS

{4, Create a scena by foilowing the instructions for Set Path Direcily in the
ment.

3. Find the frame where you want sound to start by stepping through the s
using the arrows at the potlom of the main soreen.

3. Select Sound in the Goodies menu. A piano keyboard with a musical st
top will apgear. The entire staff represents ONE frame of your scene. The nu
the left of the kevboard indicales which frame.

4. Select tone curation from the seven available on the lower left area oi th
5, 7o the upper right of the keyboard are thiee waveforms that determine i
will sound: Long Square, Short Sguare and Noise. Setect the Short Square v
(Note: the Noise wave has no pitch values.) )

6. Move the cursor to the piano keyboard and press the mouse button. You
speaker will make a sound and anote will appear on the music staft above U
kayboard. 3 '

7. Click the right arrow {0 advance the scene one frame forward. The numt
left of the ksyboard indicates the scene frame. (You can also use the « and
— arrow keys 1o back up and advance the frames.)

8. To ses whers in the scene you are, click Ses, and the currdnt frame fror
scene will appear. You can step through the scene by pressing the arrow key
the mouse buttas or press ESC to return ta the music editor, -

-9, Repeat steps 6 and 7 several limes, moving the cursor over differait key
piano keyboard. You can also insert rests (pauses) by selecting them from th
‘right area of the screen. S : . ' n

40, Select Hear to listen to the music in the current frame.

11, Toclear notes om a frame select Erase. - S S

.12, Repeat steps 6 and 7 several times again, sometimes putting more the

“note in a frame. S R L

13, - To getrid of an indévidua:l note, s’e|éct";t)eiete, ';)o'i_nt_ 't:h'e: _c_urs_@if'

ON THE MUSICAL STAFF and click the button, - iR e
g 4. Toinsent & note between two other notes selecl insert, point the cursor
" “the notes ON THE MUSICAL STAFF and click the button, A verticai ine

o o “the staff, Any future notes that you enter wilt appear dirgclly to the left-of this
48, Whed you are finished using the sound editor, select Done. -

one of
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WORKING
BLENMENTS

As.you work with Animate you will be manipulating several different kinds of files:
worksheets, characters, backgrounds, scenes and pictures. Each one of these files
has a special purpose as described below:

Worksheat

A worksheet is your animator’s sketchpad, created with the Graphic Designer. When
you save a worksheet file on a data disk you are saving the image you see on the
screen. A workshestis used o dwveiop your animated characiers and usually con-

fains shape drawings enclosed in frames.

Characier

A character is somathing drawn in the Graphic Designer that animates, When you
sequence frames on a workshaet you are actually creating a character. Until the
frames are actually sequanced, all you have are slalic shapes, When you save a
character {o disk you are saving the frames you sequsanced, in the order you
sequenced them. You can than use the characler in the Seene Designer.

If you destroy a worksheet, you wort't desiroy any characters sequencad and saved
from that workshest, but you witl no longer be able to make any changes 1o thera, or
make new sequencas from that worksheet, It’s a good idea 10 keep your worksheets
around, even when you've finished develeping characters from them.

Backgrounds

As with a worksheet, whan you save a background, you arg’saving the image you s
on the screen, excapt thare are usually no frames on & hackground. tf you do happer
to save a background that has frames on it, the frames will simply be treated as gray
rectangles,

Animate saves backgrounds in a special way by compressing them so they take up a
fitthe space on the disk as possible.

Piciures

A picture is any screen drawing created independently of Animate. Pictures are
toaded and saved using the Transfer Pic feature. T

Using Transfer Pic you can even load singie hi-res pictures, Animale will automaticall
convert them to double hi-ras, Transfer Pic can also save double hires screens as sis
gle hi-res pictures. .

IU's important to note that a picture is different from a background. Backgrounds are
pictures that are saved irs a spacial way so Lthey can be used by Animate in scenes.
Backgrounds also take up less space on a disk than piclures do. :

USING ANIMATE WITH
s DAZZLE DF%AW

APPENDIX Il === - S—

If you use Br@derbunds Dazzle Draw pairt program you may find it convenient tc)
develop your character. drawings and backgrounds in Dazzle Draw and then toad

_them into Animate for frames, sequencing and inclusion in scenes. 3
" To use your. Dazzle Draw. work as an Animate workshest, you must first save the Daz
- zle Draw picture on a da_za disk, quit Dazzle Draw, boot up Animate and'use the Trans
~“fer Pic-function td load in the Dazzle Draw picture. Aﬂer you ve femahed worki ng on. it
in Ammate make sure yau saveitasa worksheet. T
o you want o use a Da:me Draw picture asa background for an Ammdte scensa, foiio
' _the proccdure in the abwe pafagraph lotoad it mto Animale, then save il a3, a ba{:k
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ground. {Dazzie Draw pictures are not the same as Animate backgrounds. See
Appendix | on page 40, for more information about pictures and backgrounds.)

To wark on an sdsting Animate worksheet or background in Dazzle Draw, use Tr,
Pic to save the fla as a picture, then load it into Dazzle Draw.

APPENOIX H

Prolos AND
ANIMATE

Animate uses Aoaple Computar’s ProDOG filing systern. ProDOS stands for the

professional £sk Operating System for the Apple I series of compulers. Basical
“oparating sysizm’” tells the computer how to keep track of the files on a disk. Pro
has been desigred to identify individuat disks by narme, rather than by the disk d
the disk happens o be in at any given time. Each disk is considered a voiume of
mation and is izntified by its Volume Name. g

Whan you formzt a disk for use with ProDOS, you must type in anpame for tha v
The informatics on a volume is divided into filas. To load {or save or deleis) a file
PrDOS must Laow both the name of the file and the name of the voluma it's on.
Ciherwise, Prol08 may not find it

The prefix s 2 shortcul supptied by Prof3085 to help you organize your filss. You

set the Prefix 1o the name of a volume, and then load {or sava or delete) & file by
plying onfy the fle name — ProDOS will add the file name to the end of the Prefix
identify the righ! file.

PraDOS has & special type of file called a direciory file, of just a directory. A dirg
contains the names of other files which are considerad to be within the cirectory
Thus, a volums is a little bil like a file cabinet, a directory like: a file drawer, and
saved within the directory like individual file folders inside the file drawer.

Animate provicss two speacial commands 1o help you with ProDOS - Prefix and (
Line. Prefix lete you change the name of the prefix ProDOS automatically adds t-
file names you type, and On Line will tell you the names of aii the voiurnEs in the
drives connectsd to your computer. Remember that the prefix can only bz a volu
name ar a volume name followed by a directory name.

UNE-DISK 3.5

APPENDIX 1V === i -

Animate supparis Apple's Disk 3.5 as a data disk drive. If your system has more
ona Disk 3.5 imerface card, Animate will select drive 1 of the interface card in thi
highest numbe-ad slot when formatting a data of show disk.

APPENDIX Y

FRAMES

.- movies,

Graphic Designey Frames

13
in the Graphic Designer, frames are used (0 define which portions of the screen
meant to be animated. To animate the frames, you have lo pul them in arder by

* sequencing them. When the frames are rapidly displayed, one after anctherin!t
" sequence you selected, the images in the frames, your “charactes, will appear b

move. This techinique is known as “cell-animation’, and Is widely ysed in Zartoon

In Animate, frames apbear as gray boxes on a worksheet. Oten one of_tﬁ'ée hoxe
be highlighted with a white border, indicating it is a sequenced frame that was 1t

e ‘modified or reviewed, Some important rules about frames that you shouid alway

.. ‘keepin'mind are: -

"4, ‘Frames cannot be put within or around other frames.
“2.. Frames cannot cross over of into other frames. -




APPENDICES

3. For consistency and ease of editing, it is best to keep the same frame size for all
the frames of a particular character. When the frame sizes are all the same, it's easier
to rmaintain the relative position of a character from one frame 1o the next.

4. Avoid making your frames any larger than they have to be. When your character
is arimating, the entire area bounded by the frame is redrawn for each character posi-
tior. The larger your frame size, the longer it will take to animate. The three slandard
frarre sizes provided in the Stnd. Frames option are good examples of frame sizes
that animate at reasonahle speeds. '

A. ! you want to animate a very large character, it will usually move faster if you
break it down into smalier parts and animate those individually. For example, a giant
mo.ﬁ:te{ contained entirely in one frame would animate much si owr. than the same
monster broken down into several different parts, such as arms. head, legs and body.
in tha Scene Designer you would just put each of the paris toget her defmmg paths for
thers liks any other character,

Scene E)es;igﬂer Frames

In tra Scene Designer, frames generally refer to the lenglh of a particuiar scene. Each
frame of a scene also corresponds to a frame of a character's animation.

When in a scene, a character will cycle through its own frarme sequence. For example,
if a walking man character is made ap of 8 frames, when you introduce it inio a scene,
the animation will cycle through frames 1 thru 8 repeatadly.

You can aller the range of the cycle with the arrows under the character display in the
Scene Designer. This is useful if, for example, you have drawn a spaceship that flies in
4 of its frames, and explodes in the last 3 frames, If you want to show the spaceship
flyir:g for a time before exploding, you can set the cycle to repeat frames 1 thru 4, and
have the ship just {ly, When it comes lime for the explosion, the cycle is set for frames
5 thru 7 displaying just the explosion. -

- APPENDIX VI .

MASKSE

i

White the standard masks that Animate generates are ﬁdequate or most situations,
thers are imas whan you may want to modify or create your own.

For xample, If you create a character that is a round ball with biack spots on it and
anirnale it over a colored background, the background will show thraugh where the
black spots appear. Your red ball will seem to have holes in it. To make the entire ball
appear solid you wilt have to change the existing mask.

Befora you can edit the mask, you first need to know what it looks fike. Here's how o
expase the mask on the screen:

irst you need to create a character: Select Stnd. Frames in the Tools menu.
Select 18 from the tool window. \

Select Draw/Preview in the Tools menu. -

Select a color from the palette and a brush qhapp and size.

Draw some shapes in the first three frames on the top line. {For the puzpo&;m of

" this sxample you can just draw some doodlea there will be plenty of iime to get artis- . '

seqguancing the frames,

' 9. . Select the first.irame. by clicking on the Arrows in Ehe tool wmdow untal the number
1 ag:@ears The white frame border indicates the frame seiected ' :

: .',":Ma»{ﬂ sure the upper !eft corner of the box is wuthm the frame

tig fa*br)
§.- Selectthe Frame Sequenoe icon. The cursor wm turn into a pomzmg Emger _
7. Foint to the interior of each frame. one at a tnme You have creagted a characler by

8. - Select Custom Mask in the Tools menu.

16, - Click over Paste Mask in the tool window. " '
-Move the dotted line box to the frame directly beiow Ehe frame ymu selerted
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07, You can.now assign one of the mask drawings to t'_he"s;h'é_ﬁ_éi i_h'ff_ra_'m;e_a_;'_i
- inside the desired‘f,sj,an"te.;A_winqow;wi!l a_ppqa«,r.in the middle.of the screen
you what your character 100Ks like against 2
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12. Holding the mouse button down prass the space bar to align the box i
frarne. Release the button, You have just pasted the mask for shape 1 into Ul
below it. :

13. Repeatsteps © through 12 for the remaining two frames.

{Note: In our example we had plenty of extra fremes on the screen (o use 0
masks. If you generaie frames with the Make Frames option you may only h
enough frames on the screen for the character shapes. In this case make
for the masks by using Copy Frame in the Edit menu.]

When a character is animating in & sceng, the rmask is superimposed over |
ground, “behind” your character, and requiates which parts of the backgrou
through and which are complelely covarad by your character. Generally, ea
the mask that is white is opaque; you cant see through it. Each part of the
is black you can see through, . :

[Nota: Actually, white is not the only opague cotor. Each color bit that is "on
opaque, and each bit that is “off* will be clear. Since colors on the compule:
up of different onfoff bit combinations, each color wili have & different mask

tern. See Appendix Vil on page A4 for more information about color on the

" Once the masks are visible on the worksheet you can edit them using the«
" tures in Draw/Preview and reassign them to the character with Custom Md

" 4, Select Draw/Preview in the Tools menu. B

5. Salact a color from the palette and select a brush shape and size.

'3, Alter the look of the masks sfightly by drawing on each one.
. 4. \When you are finished, select Custom Mask from the toois menu.

.

B, - Select frame number 1 by clicking on the arrows in the tool window. T
. ~porder indicates the frame selected. L 0 T e T
© 6. - Click over Choose Mask in the tool windeow.

Wit h 1 h@_. ijl

whjt_e b_qc_kground
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8. Hepeat steps 5 through 7 for the remaining frames.

Note: If you resequence the frames again they will default back to the standard masic.
To use your new masks, simply re-assign them.

APPENDIX VI =

HOW COLOR
WORKS

One of the main {eatures of Animate is its extraordinary use of color, This section is an
introduction 1o how these colors work in your Apple e and lc. It's not required read-
ing for using Anirnate, but it wili help you understand how douitte high-resolution color
works. . '

How a Color Television or Moniitor Works

The inside of the viewing surface of a color picture tube is coated with stripes, hars, ol
dois of phosphor. In the back of this tube an “electron gua” shoots a baam of electrons
at the phosphors, which then give off light. The color picture lube has three different
phospors, one which glows red, one green, and one blue. Every color the eye can see
is created with one or maore of these colors, The dots of phosphors are organized into
groups of three (called triads.) Each triad is composed of one dot each of the red,
green, and blue phosphor cofors,

From your point of view as you sit at a sufficient distance from your TV or monitor, the
tight from individuat dots in a triad appears {0 be mixed together, so that you'll see a
mxiure of the three colors, rather than Individual dots of red, green, and blue. This
way each triad can display a wide mnge of colors, depencimg on the brightniess of its
three color componeants,

What the Apple does

The Apple displays text and graphics by controlling the brightness of the beam of
electrons fired by the electron gun. The electronics in the television automalically aim
the beam at each triad on the viewing surface, one after another. The Apple turns the
beam on to display bright areas, and off to display dark areas. Colors are created by
switching the beam on and off within each triad. As an example, to produce the color
violet, the beam is turned on when it is aimed at the red phosphor, off wher itis aimed
al the green phosphar, and back on again when it is aimed at the blue phosphor. it's
the combination of just the blue and red phosphors that makes viotat.

Bouble High Resolutlon Graphics

To display Double High Resolution graphics, the Apple divides each Red/Green/Blue
triad into four sections, and is able to set the electron beam on or off for each of these
sections. There is an onjoff switch, or “bit; in the Apple’s RAM for each section of each
triad, and this bit determinas whether the Apple will sat the elactron gus on or off for
that section. Each possible combination of bright and dark sections within a triad
results in a different color. This way the Apple can display any of sixieen colors at

' _each triad. Each triad (_:orr_esp_on_ds_ to a single picture element, or pixel,
‘How the Colors are Formed EE ' '

Each triad contains a dot of red, green and b}ua phosphor in that order. The flrst sec-
" tion of each triad correspands to three fourths of the red phosphor, so that when a bit
~in the Apple's RAM indicates thal the electron. gun shoutd be turned on for that sec-
tion, three fourths of the red phosphor will glow. Similarly, the second section cor-
_"--responds to one fourth of the red phosphor and one half of the green phosphor. The
¢ 2. third section corresponds to one haif of the green and one fourth of ihe blue and the
. ~fourth section to th hs of. o ' 3
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ONE TRIAD DIVIDED INTO
FOUR SECTIONS EQUALS
ONE PIXEL

Red Phosphor Green Phasphor gue Phosphor

Fust section Second section Third section Fourth section

How Colors Interact

As you waich your monitor, you'll somelimes see a mixture of colors (or”
between pixels of different colors, The reason is simple — any thres cone
phor dots are capabie of displaying any color. Consequently, any three ¢
phor dots —for example, two from one triad (or pixel) and one from anotl

“interact, mixing their Hight together Inio possibly a different color. For o\<

pixel displaying blue {baam off for red and gresn, on for blue) is just to
triad displaying red (bearn on for 1ed, off for green and blue), the iigl'it fr
and red phosphors will mix together and you will see the color as violat.
you inspect the color closely with the Zoom command, you'll see a blue
red pixel,

APPENDX VIH

RGBS MOGNITOR

Animate supports “mixed mode” RGE display. Mixed mode allows mong
color to be displayed on the screen al the same time, resulting in easy t
windows and diatogue boxas,

If you have an RGB monilor that does not hava mixed mode capahilities
played in Animate's menus, windows and dialegus boxes will be difficull
order to get more information on the screen, Animate uses a smaller for
instances which does not display wsll on non-mixed mode RGE. Howeyv
antmated graphics display well.

APPENDIX IX = e

1 the o

PROGRAMMER'S
: AIDS

The back side of the Animate Demonstration Disk Show Disk contains ¢
animation utilities that programmers can incorporate into their own BAS
biy language programs. To access the ulifities, simply boot the back sid
Demmonstration Show Disk and the Programmer’s Aids ménu will appear

- Brief explanations of the utliltses can be found on the diSk More detailec

. IS outlined bolow

| ‘Watch Command for Applesoﬁ

_' The WATGH cormand i is an added ProDOS command whmh aliows‘ ym

' .f-Syntax ist WATGH <scenenamo> -

run a scene from within an Applesoft BASIC program.

" The command must first be installed, either by selecting the optlon {rom
v mmel's Alds menuy, of by issuing the command BRUN WATCH CMD 1ro
oo Applesoft command prompt. - - :

Once lnstaiied the command fnay be used either it 1mmodsato (from thf
eferred (thhm a program) mode using those convenhon i
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: _'_"DD Use the one compaubie with your assembler, <"

| © The Label option defines a Tabel that will be lised at the stasf of each seq ence im
o 4:-Zalong with the sequence number, The default label is SHAPE Selectmg thxs opuon
L f ‘allows ycu to type in a new labeE up to 16 characters iong s .

Where < scenename> is the name of the scene file in the current default volume
directory. Note that although the file is saved by the Animale program with "SG”
praceeding the scene name, these characters should NOT be included in the

< scenename > parameler. <scenename> must be a legal scene name, as used by
the Animate program. Only the actual scene name should be given, without a path-
name prefix.

if the scene includes & background, the background file must reside on the volume a
well. Use the ProDOS PREFIX command to change the current default volume {sea
your ProDOS manual for details.)

if the scene file is not on the current volume, or if its background file is missing; the
ProDOS error  PATH NOT FOUND - will be given.

Because of restrictions in memory when using Applesoft, the WATCH command may
not be able o handle large scene files, If your scene uses many character shapes, or
farge character shapes, or if it is quite long running, it may not fit into available mem-

ory. If this is the case, the ProDOS error  PROGRAM TOO L/’-\PGE, will be given.

Since a large amount of memory is required by the WATCH command to load and run
a scene, it may not be usable with very iarge Applesoft programs, The WATCH com-
mand uses both hi-res pages, plus the area between $5000-$8000 when callad. in
addition, HIMEM is lowered fo $9400 (normal is $8600) to allow for the command han
dler itself. This feaves $8000-$9400 for Applesoft string storage or user subroutines.

Although Applesott is not affected, locations $26F thru $21F are used during execu-
tion, and all of auxilliary memory and auxilliary bank- swnrhed {fanguage card) mem-
ory is used as well.

After execution, the WATCH command returns the display to the mode it was prior to
execution. Hi-res dlsp!ays crealed by your Appiesoft program will, however, be
destroyed when a scene is run.

Stape Gutput for Assemblaers

This option is intended for assembly language programmet (s whao would like fo use
characters generated with Animate in their own programs.

The utility, named SHPGOUT, may e selected from the Programmer’s Aids menu, or
by using the ProDOS “smart” run command: -SHPOUT. |

Selection of aptions from the main screen is accomplished by moving the * > " pointer
with the arrow keys. Press the Space Bar to ¢change an entry.

Selecting the Character file option presents you with a screen similar to the fite opera-
tions window in Anirnate. Select between Prefix, Online, Okay, or Cancel by pressing
the space bar. Select a fite from the list with the arrow keys, Place the opyon bar over
Okay, and press the Return to load the Character.

Selecting Ouiput file will first ask you where you would like to send the outpul. You
can choose from either a ProDOS text file, the screen, ar a printer. It you choose to
send your output to a file, a filing screen like the one used in selecting a Character will
appear. Select the destination file with arrow keys, or type in the name. Place the
option bar over Okay and press return to select the file.

|
- i
The ASCII MSB option toggles between “Off" and "On” when selecled. Sorne assem-
blers expect the text files to be in Negative ASCI| format (MSB on.) Others expact
Positive ASCH (MSB off ) Set th:s optlon accordmg to the requ&rements of the assem-
bler you are using.

The Method option loggtes between “Columns and "Rows” This deiermme whether

the character will be listed as verticle columns of bytes, or as horizontal rows, The
- choice you make depends on the nature of your shape drawing routine. The example
‘drawing routine (DRAW EXMPL S} mcluded on the Programmers AIdS disk uses the
- Column method. . S

The Pseudo-Op seiacuon togg!es between the DFB pseudo op and the H
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The Header option defines a line that will appear as the first line in the
this option allows you to type in a new headsr, up to 28 characters long

When you have set ail the parameters, press ESC to output the Charac
image definitions to the file, screen, or printer.

Changing the Default Vahses

Once you find the values you use the most when using SHPOUT, you i
madify the program {o use these as the default values. Here's how to d

First, BLOAD SHPOUT, TSYS,A$2000
Then, CALL - 151

The parameters to modify occupy locations $2006-$2038 as iollows:

FUNCTION ADDREGS # OF BYTES
ASCH MSB $2008 1
Method $2009 1
Pseudo-0OP $200A 1

Label $2008 16
Header $201C 28

If you are using a printer which requires an initialization string, you mz
string, in ASCIL, in hytes $2038-$2047.

When all the values are set to your liking, re-save the file by typing (38
SHPOUT,TSYS,A$2000

Example of Drawing Boutine

The Programmer’s Aids disk includes an exarnple source file DRAW.E
corresponding object file narmed DRAWOR, which can serve as a Im
double hi-res drawing routines. You may BRUN DRAW.OBJ to see wh
like.

The source file is in positive ASCHL

e ARPENDIN A e T

USING ANIMATE
PHINT QUTS

CFLIP BOOK:

 ROTOSCOPE:

* disk. Try to space them avehly. : S0
. Cut a narrow slit that you can seé through, about 2" long, in a plece
‘.. “Puta pin through the center of the disk and stick it into a pencif eras

.. pengcil inone hand, gpin the disk and look through t

. where yo

The print outs that the Print Character aption generates can be used
to show off your animated characters to friends, by making simple an
Here are just a few ideas:

Flip'bookﬁ can easily be made by cutting out each frame of your cha
them in order and stapling therm together at the top. To see your cha
simply fan through the "hook” with your thumb. }

Gut out your printed character frames and paste tham, in sequence,
disk, about 67" across, so that the top of each frame is near the out

he slit at the top

u should see your character in motion. -
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Cut out the printed character frames and paste them, in sequence, onto a long stiip of
cardboard, so that the bottom of each frame is near one of the long edges of the strip.
Cut narrow slits that you can see through, about 2" long, along the opposite edge of
the cardboard strip, Position the slits between aach of the character frames.

Bend the strip so the two ends louch and paste them together. The character frames
should be on the inside.

Put the disk on a record turntable and either turn the record player on, or spin the
turntable by hand, while looking through the slils. You shouid see your character
animating,

{Mote: You can bulld an elaborate zoetrope with Braderbund's Toy Shop™ program,

tool}
AT T T T
Ty
T i S L '
T

b

 Visit your local hobby or art supply store for books on how lo make other animation
-1oys, or use your own imagination to come up with some animation “gizmos” of -

S oeyourownl

" Probos and ?roDOS Disk Formatter are é’o;ﬁyrighied prégrémé of Appla Computer Inc.

licensed to Broderbund Software, Inc, to distribute for use anly in combination with Animate.

- -Apple Saftware shall not bs copied onto another diskette (except for archive purposes) or Into

. memory unlass as part of the exgcution of Animate. When Animate has completed execution -

APPLE COMPUTER INC. MAKES NO WARRANTIES EITHER EXPRESS OR IMPLIED, =
BEGARDING THE ENCLOSED COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY

Pple Software shall not be used by any other program, -0

ORITS FITNESS FOR ANY PARTICULAR PURPOSE. THE EXCLUSION OF MPLIED WAR-

‘RANTIES IS NOT PERMITTED BY.SOME STATES, THE ABOVE EXCLUSION MAY NOT APPLY
-.TO YOU. THIS WARBANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY."

7 BE OTHER RIGHTS THAT YOU MAY HAVE WIS VARY ot arkre e hinr
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GLOSSARY =

{Hote: Functions that are included in Animate menus and
tool windows are shown here in all capital lelters.)

ABOUT ANIMATE: ‘
A CROWN menu function. Gives a copyright notics with the
names of the author and pubtisher, and copyright date,

ADJUST COLOR:

& CROWN menu function. Calls up a screen with & color
boxes 10 tse as a visual aid during the manual adjustment of
your color monitor or TV scraen, :

"Baot Up™ '

Tho process in which a program is automatically staried by
inserting a disk into the computer's disk drive and lurning on
the computer.

CAPTURE:

A Graphic Designer EDIT menu operation. Lets you modily
your work, With the CAPTURE function, you can define a sec-
tion of the screen and then CUT, COPY and PASTE il, FLIP i
horlzontally or vedically or INVERT colors in that section.

CATALOG:
A fist of file names on a disk.

Ceil-Animation: )

A style of animation where the object to be animaled is drawn
throughout several frames, or cells, The frames are rapidly dis-
piayed In sequence to give the illusion of motion.

Characier: :

Asy elament of a scene that has a defined path. Characters
ara crealed in the Graphic Designer by sequencing frames on
a worksheet,

Charvacter Display; :

Sguare area on the right side of the Scene Dasigner’s main
screen. Shows the currently selected character from the
character list.

Character Lisls

Rectangular area on the left side of the Scene Dasigner's main
screan, lisling characters that ara available for inclusion in a
scane,

CHOOQSE MASK:

A CUSTOM MASK feature. Lets you asqsgﬁ a mask foa pamc.-
o 4uear shape

CCLEAR ALL:

A Scene Designer EDIT menu functlon Erases all Chdt’al...t?t’_‘:‘
paths, background, sound and text. Clears the computer's

" .mesmory so you can start cr_eaiing a scena from seratch,

' CLEARBG: : R
-+ A Bcene Designer EDIT menu fUﬂCUOH Erases a scenes SICE
i .':':background to black i C s ey

. Ing acrf“wss the screen as you move the mome

CLEAR IMAGE:
A Gragnie Designer EDIT menu function. Erag
of a calt-frame,

CLEAR BATHS:
A Scera Designer EDIT menu function. Erase:
paths in a scena.

CLEAR BCREEN: _
Grachic Designer GOGDIES menu function.
wing from the sereen and "clean your

o pressing down and than reteasing of
= {or other input device) to activate differ
usad in Animalte,

'i “oif sereen’ area in the computer's me
section of your drawing that you have ¢
ded for future use. I holds one captured

COLOMA:

A Graghic Designer GOOMIES menu function.
chooss hetwesn drawing tn color or black and -
magnity sections of your drawing. Usad with {h
fanction. -

COLOR

AScens De‘s*gner GOQDHES menu fun(‘imn A
choose Detween creating a scene for & monocr
monitae,

copRy:

A Grapnic Designer EDIT menu function. Used

“UHE‘. » allow you to copy a seclion of your dra
is duptoate onto ancther part of the screen,

+
COPY: )
A Seens Dasigner EDIT manu function. Allows
sectiary of {rames, characlers path or sound fros
scene 5 another, '

CORY FRAME:
A Graghic Designer EDIT meny function, Aflow
cate a frame and paste copies 0l it on the scree

CROWHN menu:
The mesnu at the upper left- hand corner of the s
includss the pull-down functions ABOUT ANIM,

ABOUT .. ., ADJUST COLOR, PRINTER SET

AN;MME N

. _'Cursm* e
. The smal white arrow or other shape (queshoa

pamt Brash, ete) that functtons as a poinerorg

'}_cusmm MASK‘ i
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CUE

A Graphic Designer EDIT menu function. Used with the CAP-
TURE and PASTE operations, Leis you lift off a section of your
picture and place it onto the "cliphcard” so you can PASTE it.

Cycia:

The range of frames that a character repeats when following a
path in a scener normally from the first frame thru the last
frarne, but the range can be modified in the Scene Designer.

DELETE:
A FILE menu function. Used to remove files from your data
disk.

" DELETE,

A Scane Designer EDIT menu function. Allows you to remove
a section of frames, a character's path or sound from a scene.

DELETE:
A SCGUND feature. Lels you remove notes from the musical
stafi.

Dialogue Box:

A box that appears on the screen which sels up a “dizlogug”
between you and the computer. It provides information and
asks guestions, '

BOKRE:
A SGUND fealure. Returns you o the Scene Designer's main
sCreesn.

"Bragging the Cursor™
Refers to moving the cursor by pressing down the mouse but-
ton, moviag the mouse, then releasing the bution,

DRAWIPREVEW:

A Graphic Designer TOOLS menu function. Lets you craw
characters, backgrounds, sequence frames and preview
maticn.

EDIT menu:

In the Graphic Designer includes the pull-down meny opera-
lions: CAPTURE, CUT, COPY, PASTE, CLEAR IMAGE, COPY
FRAME, CLEAR FRAME,

EDIT menu:

“In the Scene Designer includes the puil-down menu opera-
tions: MOVE, COPY, DELETE, CLEAR PATHS, CLEAR B(G,
CLEAR ALL.

ERABE: ‘

A SQUND faature. Clears the currently disptayed musical staff.

FILE menuw
In the Giraphic Designer includes the pull-down menu opera-

lions: LOAD, SAVE, DELETE, TRANSFER PIC, MAKE DIREC- |

TORY, FORMAT DISK. Lets you save worksheets, charactars,
backgrounds and pictures onto a disk and then retrieve them
for later use. R e _ ‘

-' FILE moenu: o

in the Scene Designer includes the pull-down fnéhu opera-

- tions: LOAD, SAVE SCENE, DELETE, MAKE DIRECTORY,

FORMAT DISK, MAKE SHOW DISK. Lets you load back-

* - grounds and characters to make scenes with, and to save the 7
L scenes.- oo e e S

sk andt #lo the computer's memory, -

FLIP HORIZONTALLY & VERTICALLY:
Functicns is the CAPTURE tool window. Allows you to flip
definec areas of the screen either vertically or horizontatiy,

FORMAT DISK:

A FILE mena operation. When you want to save pictures on
a new <zla disk, this operation prepares the disk o receive
inforrretion from the compuler.

Frams:
in the Craphis Designer, a section of the screen (called
“eell"} 183l coMains a single character image.

Frame:
In the Szenz Designer, measures the length of your scene.

Gen
A Scene Designer function. Runs a scene from beginning ic
and.

phic Designer includes the pull-down menu opera
CEFID COLOR, CLEAR SCREEN, PRINT SCREEN,
PRINT 2HARACTER. Thase are "goodies” thal let you
anhance your work, but a-ent essential to using Animate,

GOODES;

Inthe Scane Designer includes the pull-down menu opera-
tions: & A, STAMP, TEXT, REMOVE TEXT, PRINT
SCREE?, SOUND, These are "goodies” that let you enhance
your work, but aren'l essential to using Animate.

GRAPHIC DERIGNER:
A Sceng Designar TOOLS menu function, Takes you 1o the
Grraphic Designar. .

Graphie Deslgner:
The par of Animate where characters and backgrounds are
davelopsd,

GRID:
A Graphio Designer GOODIES meanu function that adds a vis
ual aid t the ZOOM operation. Overlays an outline of contra:

ing lines <ver the magnified section, clearly delinealing each

pixel. : ‘
: ¥

HEAR:

A SOUMT festure. Lets you listen to the music that is current

on the musical staff. <

HELP AB0UT:
& built-in zssstance toot in the CROWN menu. Gives you @
<rription of any Animate function you've selected.

INSEAT: - _ - -
A SOUNES feature. Lats you enter notes on the musical staff i

‘batween <ther notes thai are already there.

INVERT: .

A function in the CAPTURE tool window. When active, this
function =il change all the colors in the captured space to

their “opgmsits” colors, (Example: black changes to white.)

_ AFILE menu aperation. The process of retrieving a saved {
““worksheet, character, background, scene of picte froma |
i
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MAKE DHRECTORY,
A FILE menu function that uses ProDOS to let you create a
multi-level filing systern for your data disk.

MAKE FRAMES:
A Graphic Designer TOOLS menu function. Lets you creala
custom sized cel-animation frames.

MAKE SHOW DISK:

A Scene Dasigner FILE menu function, Craates special data
disks that can be used lo automatically run scenes creatsd
with Animate,

Mask:

Regulates how a character wilt look when placed on a colored
background. You can alter masks by using the CUSTOM
MASK function.

Mernus:

A screen display of a list of operations, In Antmaie’s Graphic
Designer the menuy names appear as blus boxes across the
top of the screen. In the Scene Designer thay appear as green
boxes. The five menus are; CROWN, FILE, TOOLS, EMT, and
GGODIES.

MOVE:

A Scene Designer EDIT menu function. Aliows you to reposi-
tion a section of frames, a characler’s path, or sound within a
scene.

PASTE:

A Graphic Designer EDIT meau function, Used with CAP-
TURE and CUT or COPRY to reposition or rsoroduse "captured”
sections of the screen.

PASTE MASK:
A CUSTOM MASK featurs. Lets you display a shape's mask on
the screen,

Pathi:
The course a character foliows in a scene.

CFF:
A DRAW/PREVIEW feature. Turns the previsw window off and
“puts it away”

Picture: _ _
Any full screen drawing that has nhot been saved ag an Ani-
fate worksheet or background.

Pixel:

An abbreviation for “picture element,” or the smaliest building
biock normally used in a color drawing. A pixel in Animate is
made up of 4 dots or “bits” of color.

Preview Window:

- ADRAW/PREVIEW feature. The area of the scregn that dls«
. plays a characlers motnon

PRINT CHARACTER;
A Graphic Designer GOODIES menu function. Lets youprinl .
_-out on paper the series of framas that maks up a character.

The character f.ames are prmled oul |n lhar sequenced order.

' PRINT SCREEN: - = ' 3 B
A Graphic Designer GOODIES menu funcmn Lets you prmt

oui on paper lhe :maga you have on your screen

GLOSBSARY

PRINT SBCREEN:
A Scene Designer GOODIES menu function.
on paper a “stilt frama” from a scene.

PRINTER SETUP:

A CROWN menu funciion, Asks you to enter
Card, and Slot Number information. For Anirm
these settings must mateh your equipment.

FRIORITY:
A Scene Designer function, Lets you aler whi
pass in front of each other in a scene,

Frols:

. Stands for "tha Professional Disk Operating S

the Apple § series of computers. Basically, it i
instructions the computer follows to keep trac
the files on a disk. .

Prompi:

A message or quesfion to you from the compt
appear on the screen and either tell you how !
you lo provide further infoymation.

"Pulling Down Menus™

Refers to the method of choosing functions in
pointing and pressing the mouse over a ment.
of the sereen, then moving down {he exposed
and slopping on the menu function desired.

GEUIT ANIMATE: .
A CROWN menu function, Lets you exit Anim.
start up another program without turning off

REMOVE TEXT

A Scens Designer GOODIES function. Erase:
was addad to a scene with the TEXT function.
SAVE: -

A Graphic Designer FILE menu function. The
ferring a workshest, character, background or
computer onto a data disk for fuure use.

SAVE BUEME:

- A Scene Designer FILE ment function, The p

ferring an animated scene from the compuier
for fuiure use, - P

Scena:

A mini-movie or carioon that contains one or r
characters. Scenas are created in the Scene [
they can also he enhanced with sound and te:

SCENE DESIGNE
A Graphic ﬂehlgﬂ?l TOOL.S menu funclmn T
Scene Designer,

Scene Deslgner:

-The part of Anlmate where scenes are createt

SEE

oA DRAWIPREVIEW featurs Actwates the prev

- BEE: :
A SOUND feature. Lets ycu 508 the “ac,’t_ic_)n“ in
© rently affected by the sound editor. -




Seguance:
An ordered series of frames that define a character's animated

motion.

SET PATH BY LEADIMNG:

A Scene Designer TOOLS menu function. Lets you define a
palh by indicaling a destination lowards which the character
MOVes.

SET PATH DIRECTLEY:
A Scene Designer TOOLS menu function. Lets you define a
path by direcily moving the character with the mouse.

SET PATH WITH KEYBOARD:
A Scene Designar TOOLS menu function. Lets you define a
path using the Apple keyboard,

Shape:
Any image in a single frame.

Show Dish:

A special data disk made using the MAKE SHOW DISK func-
tion in the Scene Designer FILE menu. Allows you to put
together several scenes that will automaticalty run one after
another.

SOUND: .
A Scene Designer GOODIES menu function. Lets you add
music and sound effects to your scenes.

SPEED:
A DRAW/FREVIEW feature. Lets you adjust the speed of the
preview window.

SPEED:
A SET PATH BY LEADING feature. Lets you control how fast a
character will move towards its destination.

STAMP:

A Scene Designer GOODIES menu functicn: A special effect
{hat causes each frame image of a character to be "stamped”
onio the scene'’s background.

STNEL FRAMES:

A Graphic Designer TOOLS menu function. Automatically cre-
ates a page of ¢ell-animation frames. Three standard sizes are
availabla,

TEXT: : :
A Scene Designer GOODIES menu function. Lets you insart
titles, dialogue and descriptions in your scenes.

GLOSSARY -

TOOLS menw:

In the Graphic Designer includes the pull-down menu ope:
tions: DRAW/PREVIEW, ZOOM, MAKE FRAMES, STHND.
FRAMES, CUSTOM MASK, SCENE DESIGNER.

TOOLS manu!

in the Scene Designer includes the pult-down menu opera
tions: SET PATH DIRECTLY, SET PATH BY LEADING, SE1
PATH WITH KEYBOARD, GRAPHIC DESIGNER.

Too! Window:

An elongated box that appears at the botlem of the screen
when you select certain TOOL and EDRIT features. Contain
symbols for options available with the selecled feature.

TRANSFEH PIC: _ _ .

A Graphic Designer FILE menu operation, Allows you to i
single hi-res and double hi-res pictures created with other
grams, This feaiure automatically converts single hi-res pi
tures to double hi-res, and vice-versa,

URNIDG:

A featurs in the Graphic Dasigner thal lets you take back
last action you took, such as the jast stroke you drew or th
fast section you cul, copied or pasted. i is aclive when the
surrounding the word UNDO is red,

Wavetorm:

Used to define the type of sound a note will play in the sou
aditar. Three waveforms are availabla; fong square, short
square, and noise.

Window:

A box that appears over your drawing area when you seles
certain features. Conlains symbaols for oplions available, o
information on, selected features.

Worksheei:
A page of character images enclosed In frames, created &
Graphic Designer,

ZO0OM:
A Graphic Designer TOOLS menu operation. Lets you red
the magnified area you're working on, while you're workin:

Zooin Scrofler: .
A device in the ZOOM tool window that lets you reposition
magrified area you're working on, while you're working.
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