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If this Software was acquired under a GSA Schedule, the U.S. Government has agreed to refrain from changing or removing any 
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HyperCard Basics 

1:e HyperCard®program is a new kind of software a unique 
information environment and software development tool for 
Macintosh® computers. 

This booklet shows you HyperCard basics. It covers things 
everyone must know to use HyperCard documents, called stacks. 
Follow the instructions in this book to learn how to 

• look through HyperCard stacks 

• create places to hold new information 

• edit text on cards (the HyperCard basic unit of information) 

• search for information 

The HyperCard software included with your Macintosh computer 
allows you to use any HyperCard stacks that you may obtain 
from Apple dealers, Claris® dealers, from Macintosh user groups, or 
with other software packages. In addition, your Macintosh comes 
with several stacks, including a Home stack, an Addresses stack, and 
an Appointments stack. 
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The Claris HyperCard Development Kit, available from Claris 
Corporation, comes with many useful stacks, development cools, 
and comprehensive documentation in addition to the HyperCard 
software. This package is available from your authorized Claris 
dealer. With this package, you can use more advanced HyperCard 
capabilities to customize existing stacks and create stacks of your 
own. You can also learn how to use the HyperTalk® programming 
language. 

Before you begin To use HyperCard with your Macintosh, you must have either two 
floppy disk drives or one floppy disk drive and a hard disk. If you 
have only a single floppy disk drive, you can't use HyperCard. 

Before you use HyperCard or this book, you should be familiar 
with your Macintosh and its operation; specifically, you should 
know how to use the mouse and the pull-down menus and how to 
open folders and files. If you haven' t had some practice with these 
skills, see the Macintosh Basics disk for a guided introduction. 

You start up HyperCard the same way you open any program. 
Follow these steps: 

1. Start your computer, if it's not already on. 

If you don't have an internal hard disk, put yoLtr usual sranup 
disk in the internal disk drive. 

2. If your working copy of HyperCard is on a floppy disk, put it 
into your external floppy disk drive. 

3. If your working copy of HyperCard is on a hard disk, open the 
folder labeled HyperCard. 

Double-click the folder to open it. 

4. Click the HyperCard icon to select it, and then choose Open 
from the File menu. 

As a shortcut, you can double-click the HyperCard icon to open 
the program. 

HyperCard starts up, and you see the screen shown in Figure 1. 

.-----......w..iu.1!:lli: .. , ... ..l., _....... __ ---'-_........._ 

Welcome to HypetCard 
Home 

( More ) 

HypetCud !, a unique softwU'II tool that 11.Jlow• 
you to do more wilh your computer. 

With Hype1Co.rd, you W\ u=e H,me.rt" document, 
called stacb. Stacko �n help you do many dlffuent 
lhing:;-f'or example, you could UR a stack to keep 
track of your appointments, manage your expeiuu, 
learn a new language, or play music from an audio 
com�cl disc. A few st�w are lncluded here to get 
you started. ThejjyperCard Basics booklet nplaln• 
how to use them. You ean obit.in e.dditlona.l stacks 
from Apple deelers and u,ergroups. 

«11990 Aj)plt Comput...-, tno. 

Getting started If you have an internal hard disk, HyperCard and the stacks are 
already in a folder on the disk. (You also have HyperCard and the 
stacks on a floppy disk.) 

If you don't have an internal hard disk, HyperCard and the stacks 
are on the floppy disk called HyperCard Disk, included with your 
Macintosh. You need to make a copy of the HyperCard disk to use 
as your working disk; keep the original in a safe place. See Getting 
Started With Your Macintosh for information about malcing a copy 
of a disk. 

6. Important: Do nor use your only copy of the HyperCard disk as a 
working copy. HyperCard saves changes automatically as you work; 
any changes you make to the original files will be permanent. 6 

Figure 1 Starting HyperCard 
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Converting 
HyperCard 1.2.x 

stacks 

What you see on the screen is the first card of the Home stack 
Cards are the basic units of a stack; they' re similar to cards in a card 
file or pages in a book. 

When you open a stack created with an earlier version of 
HyperCard, you'll see a padlock in the menu bar. The padlock 
indicates that you can't change this stack because it's locked. You'll 
have to convert the stack to HyperCard 2.0 before you can make 
changes to it. 

- 

To convert your stack: 

1. Open the stack you want to convert if it's not already open. 

2. Choose Convert Stack from the File menu. 

HyperCard asks if you want to convert this stack to HyperCard 
2.0 format. 

3. ClickOK 

Notice that the padlock disappeared from the menu bar. Now 
you can modify your stack with HyperCard 2.0. 

� Important: If you are using System 6.0.7, you must convert stacks 
created in an earlier version ofHyperCard to HyperCard 2.0. 
System 6.0.7 is not compatible with earlier versions of 
HyperCard. � 

Before converting your stack, save a copy of it, in case anything 
should happen to the stack during the conversion process. (You 
should always have a backup copy of your work.) 

To save a copy of your stack while in HyperCard: 

1. Choose Open Stack from the File menu, and select the stack 
you want to convert, if it's not already open. 

2. Choose Save a Copy from the File menu. 

3. Type a name for the backup copy (or use default name) and 
click Save. 

Now you're ready to convert this stack. 

I 

6 Important: Once you've converted a stack to the new format, you 
can't convert it back to its original format, 6 

The Home stack Whenever you open the HyperCard program itself, you see the first 
card of the Home stack. Home is the HyperCard central stack. You 
can return to it easily from any other stack at any time. Most people 
use the Home stack as their base of operations, a jumping-off point 
for their work in HyperCard. 

6 Important: H yperCard needs the Home stack in order to work, so 
be careful not to delete your only copy. � 

The Home card on your screen contains several icons. These icons 
are active buttons. When you click any of these buttons, which 
you'll do shortly, HyperCard opens the stack represented by that 
button. While working in HyperCard, you need to click a button 
only onceto activate it--<lon't double-click it. 

•:• Other ways to open stacks: While you're working in HyperCard, 
you can use the Open Stack command in the File menu to 
open a stack And, just as with other documents, you can also 
double-click stack icons on the Macintosh desktop to open 
them directly. •:• 
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HyperCard has several tools that you use to look for information in 
stacks and to add information to stacks. The little hand with a 
pointing finger that moves around when you move the mouse is 
called the Browse tool ( �). The Browse tool is the tool you'll use 
most often. 

Browsing is the HyperCard term for moving through cards and 
stacks. You can browse through cards-within the same stack or 
among different stacks-by clicking buttons with the Browse tool. 
Try it now: 

1. Click the More button on the first card of the Home stack to 
read the additional text. 

2. Click the Previous button to go back when you're finished. 

The Addresses stack The Addresses stack holds addresses and telephone numbers. The 
information for each entry is stored on a separate card> much like in 
a card file. You can 

• 

' '·.1., .. .... -,.-. 
' 

� -- .Lu1..11 Poe 
C-purf hsme Dot Comr,ny � .. 

¢i Q 
s1, .. 1 .1 V:l m Strtt1 Find ... 

C,ty&Stato ,Other Torm. M•·u.drnsetts Show Note. 
Z,pCod.1 27111 New Cud - 

Delete Cud I • (b:)7) 555:1212 TthphOM ·- I I 

• -· rn rult l • --·- • • -·- ......... _ Appow,�ts Horrt• 

These arrows 
move you through 
cards in the stack. 

Figure 2 The first card in the Addresses stack 

2. Click the Addresses button once. 

A card like the one in Figure 2 appears. 

Opening the stack Follow these steps to open the Addresses stack: 

1. Move the Browse tool over the Addresses button on the Home 
card. 

6 

• add new cards and type in new information 

• delete cards you don't need 

• sort the cards alphabetically 

• search for specific names, addresses, or phone numbers 

• print out a listing for a single entry or for the entire stack 

If your computer is capable of sound input, you can also add 
buttons to the stack for playing sounds. (See "Adding Sound to 
Stacks," later in chis booklet.) 

, 
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Moving from card to card Notice the arrows on the right side of the card (as shown in 
Figure 2). These arrows are buttons that you can use to move 
through the cards in the Addresses stack. The arrows that point 
to the right and to the left take you to the next card in the stack 
and the previous card in the stack> respectively> one card at a time. 

HyperCard Basics 7 
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Try it now: 

1. Click the right-arrow button once. 

You should see the next card in the stack, which has a name and 
address. 

2. Click the left-arrow button to go back 

3. Click the right-arrow button to go through all the cards until 
you come around to the first card again. 

Cards are arranged in a circular fashion in stacks, as illustrated in 
Figure 3. In some stacks, however, arrow buttons on the first and 
last cards are intentionally covered or disabled, so that your path is 
linear rather than circular. 

Figure 3 The circular arrangement of cards in a stack 

HyperCard Basics 

Adding cards and 
typing text 

Two other navigation buttons appear in the lower-right corner of 
the card. The Home button, with the picture of the house, takes 
you to the Home stack when you click it. The Appointments 
button takes you to the Appointments stack when you click it. 

Most HyperCard stacks contain buttons that you can use to move 
around within the stack. Sometimes buttons have pictures-for 
example, arrows, houses, or other images. Other buttons have only 
text on them. In some cases, several buttons might appear as a list of 
choices (each item in the list would be a button). To choose an 
item, you'd click the appropriate button. The stack or its 
documentation should tell you how to use the stack's buttons. 

You can personalize all the existing cards in the Addresses stack by 
deleting the old text and adding new text. However, you'll probably 
find it just as easy to create new cards and then type the new 
information on them. Try it now to see how it works: 

1. Choose New Card from the Edit menu. 

Or click the New Card button on the right side of the card. 

A new card appears, ready for you to type your own 
information. The new card is added just after the card you were 
looking at when you chose (or clicked) New Card (see Figure 4). 
Don't worry about the new card's order; you'll learn how to put 
cards in order automatically in the next section. 

HyperCard Basics 9 



2. Type the name of someone a friend, family member, or 
business acquaintance perhaps. 

3. Press the Tab key to move the insertion point to the 
Company field. 

The Tab key moves you from field to field on a card. (A field is 
an area that holds text and other information that you type.) 
This card has six fields-Name, Company, Street, City & State, 
Zip Code, and Telephone. 

4. Type the company (if any). 

5. Press Tab to move the insertion point to the Street field. 

6. Type the address, pressing Tab after each line of the address. 

7. Press the Tab key again to move the insertion point to the 
Telephone field, and type the phone number. 

mo 

� 

Jody's Plz,..� 

Home �liv!:� --· .... 
¢ ¢ 

SbMt 2310thStmt Find ... 
C,ty&St.t• NoolumpJ9.mJ:rU1 Show Notes 

:.pCodt Ql�·--·· New Card 

Delete Card 
Ttleph- • l 41 J) .55.§�, � .! 

I • - ........ - ..... m um • ..... , ..... ,-,-·---··---- - • • ----·- Apj>oVll""'11s - • 

Or, if you want to get down to business right away, type in 
information for your neighborhood pizza delivery restaurant or 
some other vital service . 

8. Choose New Card from the Edit menu ( or click the New Card 
button) and add another name, address, and telephone 
number. 

Figure 5 A new address card 

6. Important: You don't have to save your changes; HyperCard does 
it for you automatically. As a result, there is no Save command in 
HyperCard. You can save a copy of a stack, however, with the Save 
a Copy command (in the File menu), so that you'll have a backup 
copy of an important stack before you make changes to it. � 

• 

] 

) 
j 

The new card 
(added afler the 
current card) 

OJ Cl 

The current card (the one you 
see on your screen before 
you choose New Card) 

Figure 4 Adding a new card 
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To Indieate hoff the ,leek wlll cort nune:, complete items 1 and 2. 

Sort Preferences Addresses 

The dialog box in Figure 6 appears. 

Sorting cards The Sort by Name command in the Utilities menu lets you 
arrange the cards alphabetically by either first or last name. Follow 
these steps: 

1. Choose Sort Preferences from the Utilities menu. 

E;,mpJe; 
8ffl Atl<in..., 
Mari,t Boots 
S•,..h Clor1< 
Joromo Oorn,n\ 
.>tffr� H.rm,n 
Awll Hod9t1 
Mb Holm 
.Jim P11mtr 
Enc Ou1ktnbush 
Rob-., Sh1nk 

Return to Add= �1 

2. When ,:ortlng tho Ott.ck by Mme: 
O Sort by first name 
® Sort by l,ct ne.me 

, 1. How did you enter the names 
ln this $11-Ck 1 

® First name fir.:t 
O Lut nune fln;t 

• 

Continue to add more cards now, if you want. If you make a 
mistake and need to change text on a card, you use the same text 
editing methods as you do in any Macintosh program. To insert 
text, click where you want to add the text and begin typing. To 
delete or change text, drag across the text to select it, and then press 
the Delete or Backspace key or just retype the text. 

You can tell whether the text on a card can be edited by moving the 
Browse cool over it. If the Browse tool changes to the I-beam 
pointer (I), then you can edit the text in the usual fashion. 

·:· Getting rid of unwanted cards: The Addresses stack comes with a 
few sample cards. You can eliminate the cards you don't want: 
Go co an unwanted card and choose Delete Card from the Edit 
menu, or click the Delete Card button on the right side of the 
card. Or, you can simply select the text on a card and type over 
the old text to replace it with a new entry. •!• 

Adding notes You can type additional information about any of the people in 
your Addresses stack. Follow these steps: 

1. Click the Show Notes button on the right side of the card, 

A field appears for you to type into. 

2. Click in the field and type whatever you like. 

3. When you're finished, click the Hide Notes button to make the 
field disappear. 

You can make your notes reappear at any time by clicking Show 
Notes, and make them disappear again by clicking Hide Notes. 

Figure 6 Telling HyperCard how you want the cards sorted 

2. Click one of the choices under the first item to tell HyperCard 
how you've entered the names in the stack-first name first or 
last name first. 

3. Click one of the choices under the second item to tell 
HyperCard how you want the cards sorted-by first name or 
last name. 

4. Click the Return to Addresses button. 

5. Choose Sort by Name from the Utilities menu. 

The pointer turns into a beach ball; it spins while HyperCard 
put the cards in order. (W'ith only a few cards, you might not 
even see the ball, because the sorting is completed so quickly.) 

12 HyperCard Basics HyperCard Basics 13 
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6. When the sorting is finished, go through the stack card by card 
using the right-arrow button. 

The new cards you added are now in their proper alphabetical 
places. (If the card order hasn't changed, it's because the cards 
were already arranged in the order you specified.) 

6 Important: Since HyperCard saves your changes for you 
automatically, you cant undo a sort. If you think you might want 
to undo a sort later, choose the Save a Copy command from the 
File menu to save a copy of the stack before you sort it. That way, 
you'll have a backup copy of the unsorted stack. 6 

Searching for text Once your Addresses stack becomes large, you won't want to move 
through it card by card to find someone's listing. You can use the 
HyperCard Find command, which gives your electronic address 
book a big advantage over paper. Follow these steps: 

I. Choose Find from the Go menu. 

The Message box appears near the bottom of the screen, as shown 
in Figure 7. Notice the insertion point: it's automatically 
positioned between the quotation marks for you. 

. r i n d .. ·1 _ _ _ - - _ - - 

Figure 7 The Message box 

HyperCard Basics 

2. Type the first name of someone you added to the Addresses 
stack and press Return. 

You have to type between the quotation marks for the Find 
command to work. 

You should see a card with the name you typed. If another card 
in the stack also has that name on it> you might see that card 
instead. 

When you press Return, HyperCard looks for text that starts with 
the letters you typed into the Message box, starting with the card 
you' re looking at. A box appears around the found word. For 
example, if you enter "Roy" in the Message box, HyperCard 
goes to the card for A. Royce Walthrop and puts a box around 
his first name. 

Pressing Return again causes HyperCard to look for the next card 
' with the text you typed. 

•!• Check your spelling: If the Macintosh beeps ( or the menu bar 
flashes), choose Find from the Go menu a second time and see 
whether you made a typing error. HyperCard beeps to let you 
know it cant find what you asked for. You might have spelled 
something incorrectly; if not, then the beep means that what you 
asked for isn't in the stack. ·:· 

You can use the Find command to search for partial names (that is, 
the first few letters of a name or word) and for dates as well . 

•:• Another way to search for text: As an alternative to using the Find 
command as just described, you can click the Find button on 
the right side of the card, type the text you want to find into the 
dialog box, and then click OK. •!• 
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Printing addresses Using the Print Addresses command in the Utilities menu, you can 
print all the contents of your Addresses stack, or print just the 
names and addresses in a format suitable for mailing labels. Follow 
the step listed below. 

•!• Before you print: Make sure you've chosen a printer in the 
Chooser and have checked the settings in the Page Setup dialog 
box (the Page Setup command is in the File menu). •:• 

1. Choose Print Addresses from the Utilities menu. 

The following dialog box appears: 

Print oll addresses as moiling labels or as an 
address book? 

[ Cancel ) ( Labels ) (( Book Il 

Figure 8 Prinling addresses 

2. Click Book if you want to print the entire contents of your 
Addresses stack, or click Labels to print mailing labels (with 
names and addresses only). 

The pointer turns into a beach ball and spins while HyperCard 
prints the information. 

HyperCard has several additional options for printing the 
information in a stack. For a description of all the printing features, 
see «Other Printing Options," later in this booklet. 

HyperCard Basics 
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More about the 
Addresses stack 

The Appointments 
stack 

The Addresses stack has several other features-including a utility 
for transferring text to or from another file, additional card-sorting 
options, and a command you can use to mark specific cards. These 
features are described in the stack itself To learn about them, 
choose Stack Overview from the Utilities menu. 

If your computer is capable of sound input, see «Adding Sound to 
Stacks," later in this booklet, for information about adding sound 
buttons to the Addresses stack 

The Appointments stack is for keeping track of your daily 
appointments and activities. The information for each day is stored 
on a separate card. You can 

• add new cards and type in new information 

• delete cards you don't need 

• search for specific text 

• print information from the stack 

If your computer is capable of sound input, you can also add 
buttons to the Appointments stack for playing sounds. (See 
"Adding Sound to Stacks," later in this bookler.) 
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Opening the stack Follow these steps to open the Appointments stack: 

1. Move the Browse tool over the Appointments button on the 
Home card. 

If there is no card for that day, HyperCard asks whether you 
want to create new cards to include that day: 

2. Click the Appointments button once. 

A card like the one in Figure 9 appears. 
There is no Appointments card for Thursday, 
March 29, 1990. Rdd cards to include 
Thursday, March 29, 1990? 
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Figure 10 Adding cards to the Appointments stack 

Click OK to add the necessary cards. You'll see the spinning 
beach ball. 

2. If the day you want isn't in the month currently displayed, click 
the appropriate Month button to see the calendar for either a 
future month or a past month: 

· r 
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To add appointment information for a particular day, you must first 
go to the card for that day. Follow these steps: 

1. If the day you want is in the month that's currently displayed 
in the upper-right corner of the card, click the day to go to 
that card. 

Figure 9 The first card in the Appointments stack 

Adding cards and 
typing text 

• 
Figure 11 Adding cards for a month to the Appointments stack 
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If there are no cards for a particular month, HyperCard asks 
whether you want to create new cards to include that month. 
You can click the Month button as many times as necessary until 
you see the month you want. 

When the appropriate month appears in the calendar, click the 
day you want. 

3. When the card appears for the day you want, click and type 
your appointment information for that day. 

Pressing Return moves you from one line to the next. 

If you make a mistake and need to change text on a card, you 
can delete or change text by dragging across the text to select it, 
and then pressing the Delete or Backspace key or just retyping 
the text. 

The Tab key moves you from one column to the other on the 
card. (These are the two different fields on the card.) 

Moving from card to card Once you've added a number of cards to the Appointments stack, 
you can move to the card for a specific day by clicking that day in 
the calendar. You can also move forward and backward through the 
days and months in the stack by clicking the Day and Month 
buttons (respectively). If there's no card for a particular day or 
month, HyperCard asks whether you want to create new cards to 
include that day or month. 

Adding notes You can type additional information for any day in your 
Appointments stack by following these steps: 

1. Click the Show Notes button on the right side of the card. 

A field appears for you to type into. 

2. Click in the field and type whatever you like. 

HyperCard Basics 

• 

• 

Printing appointment 
information 

Using the Print Appointments command in the Utilities menu, you 
can print the contents of your Appointments stack. Follow the steps 
listed below. 

·:· Before you print: Make sure you've chosen a printer in the 
Chooser and have checked the settings in the Page Setup dialog 
box (the Page Setup command is in the File menu). ·:· 
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3. When you're finished, click the Hide Notes button to make the 
field disappear. 

You can make your notes reappear by clicking Show Notes, and 
make them disappear again by clicking Hide Notes. 

Searching for text Searching for text in your Appointments stack is much like 
searching for text in any stack. Follow these steps: 

1. Choose Find from the Go menu. 

The Message box appears. 

2. Type the text you want to find between the quotation marks, 
and then press Return. 

When you press Return, HyperCard looks for text that starts 
with the letters you typed into the Message box, starting with the 
card you're looking at. A box appears around the found word. 

IfHyperCard can't fmd the text, it beeps (or the menu bar 
flashes). If this happens, choose Find from the Go menu a 
second time and check the text you typed in the Message box for 
spelling errors. 

Pressing Return again causes HyperCard to look for the next card 
with the text you typed. 

·:· Another way to search for text: As an alternative to using the Find 
command as just described, you can click the Find button on 
the right side of the card, type the text you want to find into the 
dialog box, and then click OK •!• 



I. Choose Print Addresses from the Utilities menu. 

The following dialog box appears: 

Print appointments for: 

( Cancel ) ( 7 Days ] n Today B 

Tips on getting 
around 

When you used the Addresses stack, you saw how cards are 
arranged in a stack--one after the other in a loop, as if they're held 
together by a ring. You clicked the left and right arrows to move 
from card to card. 

HyperCard provides other ways to move around in addition to 
using the buttons on the cards themselves. 

Figure 12 Printing appointment information 

2. ClickOK 

The pointer turns into a beach ball and spins while HyperCard 
prints the information in your stack. 

HyperCard has several additional options for printing the 
information in a stack. For a description of all the printing features, 
see "Other Printing Options," later in this booklet. 

I Going Home Most stacks include a button to take you to the Home stack when 
you click it. Often a Home button has a house icon. Even if a stack 
doesn't include a Home button, you can always get to Home using 
menu commands. Here are ways to get to Home: 

• Click the button with the house icon. 

• Choose the Home command from the Go menu. 

• Press X-H. (That is, hold down the X key while you press the H 
key.) 

• Press X-M to open the Message box, type go home and press 
the Return key. 
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More about the 
Appointments stack 

Adding sound 
to stacks 

The Appointments stack contains a utility for transferring text to or 
from another file. To learn about this feature, choose Stack 
Overview from the Utilities menu, and then click the About 
Transferring Text button. 

If your computer has a sound input device (such as a microphone 
or Mackecordert-), you can use the Audio Palette to add any kind 
of sound to your stacks. The Audio Palette allows you to record, 
edit, store, and play back sounds, and add buttons to your stacks 
for playing sounds. 

To learn how to use the Audio Palette, choose Audio Help from the 
Edit menu. 
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The Recent command As you go from card to card and stack to stack, HyperCard 
automatically keeps a record of where you've been. The Recent 
command in the Go menu shows (in miniature) the cards you have 
looked at, up to the last 42. Choose Recent when you need to 
retrace your steps. Try it now: 

I. Choose Recent &om the Go menu. 

The Recent dialog box appears, showing miniature versions of 
the cards you've been through. The card you.were looking at 
when you chose Recent has a box around it. 
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r.=======,&;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;=- This is the card 
you were looking 
at when you 
chose Recent. 

Other Go menu commands The Go menu contains other commands for moving around in 
HyperCard and for displaying certain features such as the Message 
box and Scroll window. Here, s a summary: 

Command Shortcut Action 

Figure 13 The Recent dialog box 

Back 

Help 

x-- Takes you to the card you looked at just before the current one. That card 
can be in the same stack or in any other stack. 

Nor available with this version of HyperCard. When HyperCard Help is 
available, this command causes the Help system ro appear on the screen for 
easy reference while you work (Hyperfard Help is available as part of rhe 
complete Hypen.ard package.) 
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A stack might have hundreds of card in it, but i_f you've looked First X-1 
at only three cards in that stack, Recent shows only the three 

Prev X-2 cards you looked at. 

2. Click any card's miniature picture. 

You immediately go to that card. Next X-3 

3. Choose Recent again from the Go menu. Last x-4 

4. Click the image of the card you were on when you first chose Find X-F 

Recent. 

The card you started from appears. 
Message X-M 

••• If memory is low: You wont see the miniature cards in the • 
Recent dialog box if HyperCard is running out of memory. This 
strategy helps conserve space for more important changes you 
may be making to a stack. HyperCard is still keeping track of 

• 
where you've been, however. Choose the Back command (from Scroll X-E 
the Edit menu) repeatedly to retrace your steps. ·:· 

• 
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Takes you to the first card of whatever stack you're in. 

Takes you to the card just previous to the current card in the stack. This 
command moves you backward through the current stack one card at a time, 
regardless of whether you have seen those cards. (Ir's not the same as Back.) 

Takes you to the next card in the stack. 

Takes you to the last card in the stack. 

Causes the Message box to appear, with the word find already typed in 
and the insertion point blinking between quotation marks. You simply type 
the text you're looking for and press Return. 

Causes the Message box to appear with only the insertion point blinking in 
it. You can type a message such as go Home or go to stack 
"addresses" and HyperCard either takes you to the stack or presents the 
directory dialog box. Choosing this command a second time cau es the 
Message box to disappear. 

Displays a small window in which you can change the size of the visible part 
of a card on the screen. To change the size of the window in which you see 
a stack, drag with the small double-headed arrow pointer inside the Scroll 
window. To see other parts of the card in a reduced-size window. drag with 
the hand in the middle of the croll window, 
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Other printing 
options 

Print Field 

Print Card 

In addition to the Print Addresses and Print Appointments 
commands, HyperCard provides several printing options through 
the printing commands in the File menu. If you have more than 
one stack open, these commands work on the active stack ( the one 
with stripes in its title bar). This section describes each option 
briefly. 

•:• Before you print: Make sure you've chosen a printer in the 
Chooser and have checked the settings in the Page Setup dialog 
box (the Page Setup command is in the File menu). ·:· 

This command lets you print the contents of a particular field on a 
card, without printing the entire card image. When you choose 
Print Field, a dialog box appears in which you select the field you 
want to print. For example, you might want to print the contents of 
the notes field, 

This command prints the current (active) card full size on a single 
sheet of paper. The card you see on rhe screen is what you get 
printed out. 

If you' re working in a stack that has a predefmed report template, 
follow these steps to print a report using char template: 

1. Choose Print Report from the File menu. 

The Print Report dialog box appears. 

2. Choose the report template from below the dotted line in the 
Reports menu. 

If there are no report templates listed below the dotted line in 
the Reports menu, it means that the current stack has no 
predefined report templates. 

3. Click Print. 

Creating a report template 

By creating your own report template, you can specify exactly 
which fields you want to print and choose the printing layout 
yourself. You could, for example, turn your Addresses stack 
information into mailing labels of any size, or print a report that 
includes the contents of the Notes field as well as the name and 
address information for each card. 
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Print Stack Print Stack prints all the cards in the stack. When you choose Print 
Stack, a dialog box appears in which you choose card size, printing 
order, and page layout. You can also add an identifying line of text, 
or header, to each page of the printout using the text area at the 
bottom of the dialog box. 

Print Report This command lets you print the contents of selected fields in a 
stack according to a predefined report template (if the stack has 
any). You can also use this command to create a report template of 
your own, as described in the next section. 

HyperCard Basics 
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Here are the basic steps you use to create your own report template. 
You don't need to try these steps now; they are here for your 
reference if you need them. 

1. Choose Print Report from the File menu. 

The Print Report dialog box appears. 

2. Choose New Report from the Reports menu, type a name for 
your report template, and click OK 

You use the controls and miniature layout in this box to set up 
your report's format. Each cell in the layout represents a card's 
worth of information. Drag the handle in the corner of the top­ 
left cell to resize all the cells; drag the other cells to position cells 
on the page. Keep an eye on the controls in the lower-right 
corner of the box if you need precision spacing. 

3. Choose Report Items from the Edit menu. 

The Report Items dialog box appears. In this box you see a 
rectangle representing any cell in the report. (All cells will have 
identical layouts; only the information will vary.) 

4. To add report items to the cells, choose New Item from the 
Items menu. 

Report items contain information from fields, which you'll 
specify in the next step. You can resize and reposition each 
selected report item; simply drag it by a corner or by its center. 

5. To specify which field's content goes into a report item, click 
the item to select it (if its not selected already) and choose Item 
Info from the Items menu. 

The Item Info dialog box appears. Select the field you want from 
the list on the left and click the Font, Style, and Size check boxes 
to choose whatever font, style, and size you wish. By choosing a 
different font, style, or size for the item's text, you can make the 
printed text look: different from the way the text appears inthe 
stack itself 
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Quitting HyperCard 

Other uses for 
HyperCard 

6. As you finish each item's information, click OK to return to the 
Report Items dialog box. When you finish adding and 
specifying items, click OK to return to the Print Report 
dialog box. 

7. Click Print when you're ready to print. 

To quit HyperCard, choose Quit HyperCard from the File menu 
( or press X-Q). HyperCard saves any changes automatically as you 
work, so you don't have to worry about saving your work before 
you qwt. 

•:• Before you quit: It's a good idea to choose Compact Stack from 
the File menu before you quit or close a stack that you've 
changed in any way. This rearranges the current stack on the 
disk, removing any unused space so that it fits into the smallest 
possible space. ·:· 

The Addresses and Appointments stacks are only two examples of 
the possible uses for HyperCard software. People have created 
H yperCard stacks for a variety of purposes, such as 

• self-paced demonstrations and training packages for business 

• electronic, interactive directories at conventions and trade shows 

• search and retrieval software for information on compact discs 
and videodiscs 

• animated presentations with sound for use in education, 
business, and retail sales 

• database management, with graphics and sound storage 
capabilities as well as text 

• j use for fun! 
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Where to get stacks You can get stacks from a variety of sources: 

• Check with you local Macintosh user group co find out the 
meeting time of the HyperCard special interest group. Members 
often exchange their own stacks with each other. You can also 
pick up HyperCard tips and tricks and other useful information. 

• Most on-line electronic information services like Cornpuoerve'" 
and GEnieTM have Macintosh special interest groups chat 
exchange stacks and other software. 

• You'll find HyperCard stacks for sale at your local computer 
software store. 

For more information This booklet covers the basics of getting around in Hyperf.ard 
stacks. If you are interested in exploring HyperCard further, 
the Claris HyperCard Development Kit includes a number of 
ready-made stacks, tools, and full documentation for stack 
customization and development. The HyperCard Development Kit 
is available through your Claris dealer. Call 1-800-3-CLARIS 
for the location of your nearest Claris dealer. The HyperCard 
Development Kit documentation includes. the following: 

• Getting Started With HyperCard· A book that teaches the basic 
skills you need to get going, and shows you how to start creating 
and modifying stacks. 

• HyperCard Reference: A complete guide to how to accomplish 
tasks using H yperCard. 

• HyperCard Tour: A stack that introduces HyperCard concepts 
by showing you what HyperCard can do. 

• HyperCard Help: A stack that answers your questions while 
you're using HyperCard. 

• Hyper Talk Beginners Guide: A book that teaches you h.ow to use 
the Hyper Talk programming language. 
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• Hyper Talk Reference: A stack that provides easy access to 
information about HyperTalk. 

• HyperCard Q}J,ick Reference Guide: A booklet that gives keyboard 
shortcuts for HyperCard and HyperTalk operations. 

• HyperCard Script Language Guide: A book that provides detailed 
reference information about scripts and HyperTalk. 

Several excellent books have been written about HyperCard and its 
uses, such as HyperCard Stack Design Guidelines, published by 
Addison-Wesley®. You can find this and other books in the 
computer section of many bookstores. 

In addition to comprehensive documentation, the HyperCard 
Development Kit includes a number of ready-made stacks you can 
use and customize. 
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The Apple Publishing System 
This Apple® manual was written, edited, and composed on a desktop publishing system using 
Apple Macintosh® computers and Microsoft Word. Proof pages were created on Apple LaserWricer® 
printers and the QMS ColorScript 100. Final pages were produced in QuarkXPress and output directly 
to film on a Linocronic 300. Line art was created using Adobe Illustrator 88. 

Display type is Apple's corporate font, a condensed version of Garamond. Text type is Adobe 
Garamond. Ornaments are ITC ZapfDingbats. Some elements, such as program listings. are sec in 
Apple Courier, a fixed-width font. 

PostScrip1, the LaserWriter page-description language, was developed by Adobe Systems 
Incorporated. 
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